Improve default start page

RESOLVED DUPLICATE of bug 214845

Status

mozilla.org
Miscellaneous
RESOLVED DUPLICATE of bug 214845
14 years ago
14 years ago

People

(Reporter: Mathew McBride, Assigned: Mitchell Baker)

Tracking

Details

(URL)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.6a) Gecko/20030924
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.6a) Gecko/20030924

I feel that the Mozilla Start Page ( http://www.mozilla.org/start/ ) is too
focused on developers/testers instead of the end user. 

While we should encorage testing of Mozilla, I don't think politely asking every
new Mozilla user to do it through the default start page is the right way to do it.

While I should of emailed suggestions to Gerv, I'll file a bug to canvass
opinion. Perhaps we can have something simular to the Mozilla 1.0 Start Page (
http://www.mozilla.org/start/1.0/ )

I'm willing to throw in some help to create a new one.

Reproducible: Always

Steps to Reproduce:




( perhaps this should go to marketing? )

Comment 1

14 years ago
Dupe.

Only 1.0.x and 1.4.x have their own start pages because they are from the
"Stable Branches". All other releases are development milestones, though this
isn't clear to most people

*** This bug has been marked as a duplicate of 214845 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.