Status

()

Core
CSS Parsing and Computation
--
critical
VERIFIED DUPLICATE of bug 220464
14 years ago
14 years ago

People

(Reporter: timeless, Assigned: dbaron)

Tracking

({crash, topcrash})

Trunk
x86
Linux
crash, topcrash
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(crash signature)

(Reporter)

Description

14 years ago
SelectorMatchesTree   61
BBID range: 23931578 - 24111290
Min/Max Seconds since last crash: 4 - 31505
Min/Max Runtime: 5 - 89274
Crash data range: 2003-09-27 to 2003-10-04
Build ID range: 2003092705 to 2003092722

Stack Trace:

         SelectorMatchesTree()
         ContentEnumFunc()
         RuleHash::EnumerateAllRules()
         CSSRuleProcessor::RulesMatching()
         EnumRulesMatching()
         nsSupportsArray::EnumerateForwards()
         StyleSetImpl::FileRules()
         StyleSetImpl::ResolveStyleFor()
         nsPresContext::ResolveStyleContextFor()
         nsCSSFrameConstructor::ResolveStyleContext()
         nsCSSFrameConstructor::TableProcessChild()
         nsCSSFrameConstructor::TableProcessChildren()
         nsCSSFrameConstructor::ConstructTableRowFrame()
         nsCSSFrameConstructor::TableProcessChild()
         nsCSSFrameConstructor::TableProcessChildren()
         nsCSSFrameConstructor::ConstructTableRowGroupFrame()
         nsCSSFrameConstructor::TableProcessChild()
         nsCSSFrameConstructor::TableProcessChildren()
         nsCSSFrameConstructor::ConstructTableFrame()
         nsCSSFrameConstructor::ConstructFrameByDisplayType()
         nsCSSFrameConstructor::ConstructFrameInternal()
         nsCSSFrameConstructor::ConstructFrame()
         nsCSSFrameConstructor::ContentAppended()
         StyleSetImpl::ContentAppended()
         PresShell::ContentAppended()
         nsDocument::ContentAppended()
         nsHTMLDocument::ContentAppended()
         HTMLContentSink::NotifyAppend()
         SinkContext::FlushTags()
         HTMLContentSink::BeginUpdate()
         nsDocument::BeginUpdate()
         PresShell::ProcessReflowCommands()
         ReflowEvent::HandleEvent()
         HandlePLEvent()
         PL_HandleEvent()
         PL_ProcessPendingEvents()
         nsEventQueueImpl::ProcessPendingEvents()
         event_processor_callback()
         our_gdk_io_invoke()
         libglib-1.2.so.0 + 0x10136 (0x402ce136)
         libglib-1.2.so.0 + 0x11a3e (0x402cfa3e)
         libglib-1.2.so.0 + 0x11f19 (0x402cff19)
         libglib-1.2.so.0 + 0x121b4 (0x402d01b4)
         libgtk-1.2.so.0 + 0xa011f (0x401dd11f)
         nsAppShell::Run()
         nsAppShellService::Run()
         main1()
         main()
         libc.so.6 + 0x15ca6 (0x403faca6)

(24084748) Comments: Started mozilla saw the menu and the the dialog 
mozilla unexpectedly quit... I did not see a window opening. I recently 
installen RealPlayer. Is there a problem with this plugin? Removing the 
plugin diddn't help.
(24084704) Comments: Started mozilla saw the menu and the the dialog 
mozilla unexpectedly quit... I did not see a window opening. I recently 
installen RealPlayer. Is there a problem with this plugin?
(24084630) Comments: I was just starting mozilla
(23971938) URL: http://fedora.redhat.com
(23971938) Comments: Tried to open the URL above crashed
(23952251) Comments: Launching Mozilla (Mac OS X - build 2003092805). It 
crashed after specifying the profile to use
(23950373) Comments: starting it for the second time.
(23950359) Comments: starting it for the first time.
(23950318) Comments: Started the program (selected the Mozilla icon in the 
OS X application folder). Program crashed before completing its startup.
(23950237) Comments: Starting the program (selcted icon in dock)
(23950224) Comments: Selected the Mozilla Icon in the dock to start the 
program. It crashed during its start-up.
(23946673) Comments: going to load checky after new install
(23944147) Comments: Netscape 7.1 wizar faild to configure my existing 
netscape account. It never connets to the netscape network.
(23943899) Comments: starting the application after installation
(23943427) Comments: startup
(23942965) Comments: starting Mozilla
(23942950) Comments: Opening Mozilla
(23942949) Comments: Opening Mozilla
(23940789) Comments: launching app
(23940728) Comments: quits on launch does not happen with 1.5
(23940127) Comments: quits on launch
(23935120) URL: mozilla.org/themes
(23935120) Comments: Browsing the themes section after clicking on a link 
from google.
(23934124) Comments: Just trying to launch the browser that I just 
downloaded. Crashes every time.
(23933910) Comments: Crashed on launch a second time. Reverting back to 
previous 24-09-03 Build.
(23933875) Comments: Crashed on launch.
(23932218) Comments: Mozilla crashed on startup

--this bug is filed based on talkback data, don't come to me asking 
for steps to reproduce or contacts--
Are there any _recent_ instances of this?  This looks like bug 220464
(Assignee)

Comment 2

14 years ago
Timeless, please look closely at the "Build ID range" (see comment 0) before
filing crashes based on talkback reports.

*** This bug has been marked as a duplicate of 220464 ***
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
(Reporter)

Comment 3

14 years ago
.
Status: RESOLVED → VERIFIED
Crash Signature: [@ SelectorMatchesTree]
You need to log in before you can comment on or make changes to this bug.