Closed Bug 221532 Opened 17 years ago Closed 17 years ago

File->Save Page As, Webpage, complete doesn´t escape correctly

Categories

(Core Graveyard :: File Handling, defect)

x86
Windows 98
defect
Not set
major

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 115107

People

(Reporter: hhschwab, Unassigned)

References

()

Details

Attachments

(1 file)

User-Agent:       Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.6a) Gecko/20031007
Build Identifier: Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.6a) Gecko/20031007

Save URL as Webpage complete, and load the saved file in a tab, and compare.
You don´t see the boxes, like the one I will attach.
Saving doesn´t work with 1.0.2, 1.3.1, 1.4.1, 1.5RC2, Trunk.
Loading doesn´t work with 1.0.2, loops endless.
The same page saved with Opera shows correctly in some of the newer browsers
above, didn´t test all of them.

code examples:

Mozilla:
<div class="preWrapper">
<pre>AC_RunFlContent(
    "att1Name","att1Value", 
    "att2Name","att2Value", 
    ... 
    "attnName","attnValue" 
);
</pre>
</div>

Opera:
<div class="preWrapper">
<pre>AC_RunFlContent(
    &quot;att1Name&quot;,&quot;att1Value&quot;, 
    &quot;att2Name&quot;,&quot;att2Value&quot;, 
    ... 
    &quot;attnName&quot;,&quot;attnValue&quot; 
);
</pre>
</div>


Reproducible: Always

Steps to Reproduce:
1.Load URL
2.Save URL as Webpage, complete
3.Load saved File, compare
The code above should be shown in boxes like this one, 4kb screenshot attached.

There are some of these boxes in the file, this box however shows a bug:
if you hover over the scrollbar, some pixel junk is shown above it, changes
with movement, goes away when scrolling, returns on crossing the scrollbar with
the mouse.

*** This bug has been marked as a duplicate of 115107 ***
Status: NEW → RESOLVED
Closed: 17 years ago
Resolution: --- → DUPLICATE
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.