Mail Date Column - lists time of day but nil dates

RESOLVED DUPLICATE of bug 139091

Status

SeaMonkey
MailNews: Message Display
--
major
RESOLVED DUPLICATE of bug 139091
15 years ago
13 years ago

People

(Reporter: Wayne FitzSimons, Assigned: (not reading, please use seth@sspitzer.org instead))

Tracking

Trunk
x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: CANCEL - Not a problem)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.4) Gecko/20030624
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.4) Gecko/20030624

The Mail date column started listing only the time of day without any date. (I
had a screen shot I could have attached). I have no idea why it is now doing
this as it was listing dates until today. Unfortunately if I can't find how to
fix this I'll have to abandon Mail/News as it's obvious that the dates received
are most important. If the time disappeared I could live with that. 

Reproducible: Always

Steps to Reproduce:
1. There is no action on the users part. It just stopped listing the dates period.
2.
3.

Actual Results:  
No steps - it just stopped listing the dates.

Expected Results:  
Listed the dates as it was until about midday today. (7th Oct 2003)

I'd also like to know how I can export my mail if I have to change to another
product since I can't use a mail utility that doesn't record the dates received.

Comment 1

15 years ago
Mozilla doesn't show the date in the column for any mail? What is displayed in
the header date if you display the message itself?

By default the date isn't displayed for mails with the current date (i.e.
today). You can configure the columns display mode with the following prefs:

user_pref("mail.ui.display.dateformat.default", 2);  // 31.12.1999 23:59
user_pref("mail.ui.display.dateformat.thisweek", 4); // Wed 23:56
user_pref("mail.ui.display.dateformat.today", 0);    // 23:53
Some users sometimes claim about time only display for today's mail in
MozillaZine Thunderbird forums.
Christian, thanks for your information about "mail.ui.display.dateformat.xxx".
However I can not find "mail.ui.display.dateformat.xxx" keywords in about:config.
(Q1) Are value of these keywords are integer or string? (probably integer)
(Q2) Where can we find the description about these keywords and values?
(Q3) Does these keywords are supported by Thunderbird too?

Comment 3

15 years ago
Yes, these prefs unfortunatelly aren't well documented.

>(Q1) Are value of these keywords are integer or string? (probably integer)
Yes, integer.

>(Q2) Where can we find the description about these keywords and values?
The definition itself can be found at
http://lxr.mozilla.org/seamonkey/source/intl/locale/idl/nsIScriptableDateFormat.idl#41

>(Q3) Does these keywords are supported by Thunderbird too?
I don't have tested, but I'm very sure they are.

Comment 4

15 years ago
the user_pref settings work in thunderbird 0.3 on windows xp
(Reporter)

Comment 5

15 years ago
CANCEL THIS:
Shortly after initial installation I was unaware that "todays mail" is not dated
- only showing times. In other words it's by design and I now realise now it's a
good idea.

How the misconception came about:
=================================
I had just installed Mozilla not long before mid-night and imported my old mail
(which therefore had complete dates). Soon after, my new mail also had dates
because we'd passed midnight. At this stage I new nothing about that no date on
current day feature. 

The next morning - much new mail arrived and had no dates and I thought it must
have been a preference thing and thought the dates had somehow switched off.
Please cancel this - it is a design feature not a bug.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → INVALID
Whiteboard: CANCEL - Not a problem

Comment 6

15 years ago
*** Bug 225726 has been marked as a duplicate of this bug. ***

Comment 7

14 years ago
*** Bug 249899 has been marked as a duplicate of this bug. ***

Updated

14 years ago
Status: RESOLVED → UNCONFIRMED
Resolution: INVALID → ---

Comment 8

14 years ago

*** This bug has been marked as a duplicate of 139091 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago14 years ago
Resolution: --- → DUPLICATE
Product: Browser → Seamonkey

Comment 9

13 years ago
(In reply to comment #5)
> CANCEL THIS:
> Shortly after initial installation I was unaware that "todays mail" is not dated
> - only showing times. In other words it's by design and I now realise now it's a
> good idea.
> 
> How the misconception came about:
> =================================
> I had just installed Mozilla not long before mid-night and imported my old mail
> (which therefore had complete dates). Soon after, my new mail also had dates
> because we'd passed midnight. At this stage I new nothing about that no date on
> current day feature. 
> 
> The next morning - much new mail arrived and had no dates and I thought it must
> have been a preference thing and thought the dates had somehow switched off.
> Please cancel this - it is a design feature not a bug.


It is not a bug(In reply to comment #5)
> CANCEL THIS:
> Shortly after initial installation I was unaware that "todays mail" is not dated
> - only showing times. In other words it's by design and I now realise now it's a
> good idea.
> 
> How the misconception came about:
> =================================
> I had just installed Mozilla not long before mid-night and imported my old mail
> (which therefore had complete dates). Soon after, my new mail also had dates
> because we'd passed midnight. At this stage I new nothing about that no date on
> current day feature. 
> 
> The next morning - much new mail arrived and had no dates and I thought it must
> have been a preference thing and thought the dates had somehow switched off.
> Please cancel this - it is a design feature not a bug.

It's not a bug, but I don't think its a good design (default) either.  If it is,
how come people are changing them to display the date after they installed
thunderbird.  I just migrated a staff from Outlook to Thunderbird and this kind
of unnecessary "feature" just adds to user's training/orientation (and
frustration).  If Thunderbird is to succeed, it should seriously consider the
ease of transition from the competition.
You need to log in before you can comment on or make changes to this bug.