ATSUMeasureText is deprecated

VERIFIED DUPLICATE of bug 161332

Status

VERIFIED DUPLICATE of bug 161332
15 years ago
10 years ago

People

(Reporter: Usul, Assigned: sfraser_bugs)

Tracking

Trunk
Future
PowerPC
Mac OS X

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

15 years ago
When running Camino I noticed the following sentence in the console log :
"Contents/MacOS/Camino: ***
          Warning: ATSUMeasureText has been deprecated.  Use
          ATSUGetUnjustifiedBounds instead. *** "
(Reporter)

Comment 1

15 years ago
Created attachment 132879 [details] [diff] [review]
Replacing all calls of ATSUMeasureText by ATSUGetUnjustifiedBounds 

http://developer.apple.com/documentation/Carbon/Reference/ATSUI_Reference/atsu_reference_Reference/function_group_13.html#//apple_ref/c/func/ATSUGetUnjustifiedBounds

http://developer.apple.com/documentation/Carbon/Reference/ATSUI_Legacy/atsu_legacy_Reference/FunctionGroupIndex.html#//apple_ref/c/func/ATSUMeasureText


I did not buil mozilla, but camino to test my patch. I did all testings and
build on 10.2.8. Camino was able to render Japanese, Chinese and hebrew
correctly as far as I could tell.

I do not know if this API change was present in 10.1
(Reporter)

Updated

15 years ago
Attachment #132879 - Flags: review?(sfraser)
(Assignee)

Comment 2

15 years ago
> I do not know if this API change was present in 10.1

Please find out, or make a test build and have someone test it on 10.1
(Reporter)

Comment 3

15 years ago
/*
 *  ATSUGetUnjustifiedBounds()
 *  
 *  Availability:
 *    Mac OS X:         in version 10.2 and later in 
ApplicationServices.framework
 *    CarbonLib:        not available in CarbonLib 1.x, is available on 
Mac OS X version 10.2 and later
 *    Non-Carbon CFM:   not available
 */

So I guess this means the patch will not be applied until support for 10.1 is
dropped.

Comment 4

15 years ago

*** This bug has been marked as a duplicate of 161332 ***
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
(Reporter)

Comment 5

15 years ago
Verified dup.
Status: RESOLVED → VERIFIED
Target Milestone: --- → Future
(Reporter)

Updated

15 years ago
Attachment #132879 - Flags: review?(sfraser)
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.