Firebird: remove the references to files packaged as chrome://communicator/* and chrome://navigator/*

RESOLVED FIXED in Firebird0.8

Status

()

P1
normal
RESOLVED FIXED
15 years ago
12 years ago

People

(Reporter: p_ch, Assigned: p_ch)

Tracking

unspecified
Firebird0.8
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment, 1 obsolete attachment)

(Assignee)

Description

15 years ago
> grep -slr "chrome://communicator" mozilla/browser/
mozilla/browser/mozilla/browser/app/profile/all.js
mozilla/browser/base/content/browser-menubar.inc
mozilla/browser/base/content/contentAreaUtils.js
mozilla/browser/base/content/openLocation.xul
mozilla/browser/base/content/printPreviewBindings.xml
mozilla/browser/components/bookmarks/content/bookmarksManager.xul
mozilla/browser/components/bookmarks/content/bookmarksPanel.xul
mozilla/browser/components/downloads/content/helperApps.js
mozilla/browser/components/history/content/history-panel.xul
mozilla/browser/components/prefwindow/content/overrideHandler.js
mozilla/browser/components/prefwindow/content/pref-calibrate-screen.xul
mozilla/browser/components/prefwindow/content/pref-charset.xul
mozilla/browser/components/prefwindow/content/pref-fonts.xul
mozilla/browser/components/prefwindow/content/pref-images.xul

> grep -slr "chrome://navigator" mozilla/browser/
mozilla/browser/app/profile/all.js
mozilla/browser/base/content/browser.js
mozilla/browser/base/content/openLocation.xul
mozilla/browser/base/skin/browser.css
mozilla/browser/components/downloads/skin/downloadmanager.css
mozilla/browser/components/prefwindow/content/pref-calibrate-screen.xul
mozilla/browser/components/prefwindow/content/pref-themes.xul
(Assignee)

Updated

15 years ago
Priority: -- → P1
Target Milestone: --- → Firebird0.8
(Assignee)

Updated

15 years ago
Blocks: 221602

Comment 1

15 years ago
Pierre, this is essentially what bug 200142 is all about. Shall I mark this bug
a duplicate of bug 200142 or the other way around?
(Assignee)

Comment 2

15 years ago
Status:
> grep -slr "chrome://communicator" mozilla/browser/
mozilla/browser/app/profile/all.js
mozilla/browser/base/content/browser-menubar.inc
mozilla/browser/base/content/contentAreaUtils.js
mozilla/browser/base/content/printPreviewBindings.xml
mozilla/browser/components/downloads/content/helperApps.js
mozilla/browser/components/history/content/history-panel.xul
mozilla/browser/components/prefwindow/content/overrideHandler.js
mozilla/browser/components/prefwindow/content/pref-charset.xul
mozilla/browser/components/prefwindow/content/pref-images.xul
mozilla/browser/components/sidebar/src/nsSidebar.js

> grep -slr "chrome://navigator" mozilla/browser/
mozilla/browser/app/profile/all.js
mozilla/browser/base/content/browser.js
(Assignee)

Comment 3

15 years ago
simon: well, this bug is not about removing the files we don't use, but about
not using the files we shouldn't.
Summary: Phoenix: remove the references to files packaged in comm.jar → Phoenix: remove the references to files packaged as chrome://communicator/* and chrome://navigator/*

Updated

15 years ago
Summary: Phoenix: remove the references to files packaged as chrome://communicator/* and chrome://navigator/* → Firebird: remove the references to files packaged as chrome://communicator/* and chrome://navigator/*

Comment 4

15 years ago
will fixing this bug fix 210553?  sounds related, but i don't know the mozilla code.
(Assignee)

Comment 5

15 years ago
Current state:
> grep -slr "chrome://communicator"
mozilla/browser/mozilla/browser/app/profile/all.js
mozilla/browser/base/content/contentAreaUtils.js
mozilla/browser/components/downloads/content/helperApps.js
mozilla/browser/components/history/content/history-panel.xul
mozilla/browser/components/prefwindow/content/overrideHandler.js
mozilla/browser/components/prefwindow/content/pref-images.xul
mozilla/browser/components/sidebar/src/nsSidebar.js

> grep -slr "chrome://navigator"
mozilla/browser/mozilla/browser/app/profile/all.js

Comment 6

15 years ago
all.js things

chrome://navigator/locale/navigator.properties
chrome://navigator-region/locale/region.properties
chrome://communicator-region/locale/region.properties

Comment 7

15 years ago
missed one.  
chrome://navigator-platform/locale/navigator.properties

Comment 8

15 years ago
Pierre, these files are not part of the build:
mozilla/browser/components/prefwindow/content/pref-images.xul
mozilla/browser/components/prefwindow/locale/pref-images.dtd
mozilla/browser/components/prefwindow/content/overrideHandler.js
mozilla/browser/components/downloads/content/helperApps.js
mozilla/browser/components/sidebar/src/nsSidebar.js

We use other files, e.g. pref-features-images.xul, .js and .dtd.

Comment 9

15 years ago
And if you want to clean up some more, you can also cvs remove these files:
mozilla/browser/components/prefwindow/content/pref-downloads.js
mozilla/browser/components/prefwindow/content/pref-downloads.xul
mozilla/browser/components/prefwindow/content/unknownContentType.xul
mozilla/browser/components/prefwindow/locale/pref-downloads.dtd

They're now in mozilla/toolkit/mozapps/downloads.
(Assignee)

Comment 10

15 years ago
There was a bunch of unused files (24 to be precise) nsSidebar.js is used
though. And we have now to decide what to do with all these *-region files, as
alanjstr pointed.

We're getting closer...!
Current state:
> grep -slr "chrome://communicator"
mozilla/browser/mozilla/browser/app/profile/all.js
mozilla/browser/components/sidebar/src/nsSidebar.js

> grep -slr "chrome://navigator"
mozilla/browser/mozilla/browser/app/profile/all.js

Comment 11

15 years ago
Thanks so much for cleaning up. I see that we need nsSidebar.js for e.g. adding
search engines. I was confused because it's not packed into browser.jar.

As for the *-region files, we should change the references
from chrome://navigator-region/locale/region.properties
and from chrome://communicator-region/locale/region.properties
to chrome://browser-region/locale/region.properties,

as well as from chrome://navigator/locale/navigator.properties
to chrome://browser/locale/browser.properties.

Make the necessary changes/additions to
mozilla/browser/base/locale/region.properties and browser.properties, and drop
the prefs we don't need.

Comment 12

15 years ago
Created attachment 135522 [details] [diff] [review]
patch

This is an implementation of my plan in comment 11.
It was easier than I thought.

Navigator version: startup.homepage_override_url=http://www.mozilla.org/start/
Browser version:
startup.homepage_override_url=http://www.mozilla.org/projects/firebird/
My suggestion:
startup.homepage_override_url=http://www.mozilla.org/products/firebird/
This setting is commented out by the way.

I added this pref. Don't know if we need it: general.useragent.contentlocale=US


Navigator version: browser.startup.homepage=http://www.mozilla.org/start/
Browser version:
browser.startup.homepage=http://www.mozilla.org/products/firebird/

fix typo that was already fixed in navigator:
intl.menuitems.alwaysappendaccesskeys=

There are two lines left in all.js, I need some help here:
pref("intl.collationOption",		   
"chrome://navigator-platform/locale/navigator.properties");
pref("intl.charset.default",		   
"chrome://navigator-platform/locale/navigator.properties");

The other settings are identical in navigator and browser.
Note that these files are not stored in comm.jar. But why not do it while we're
at it.

Comment 13

15 years ago
Comment on attachment 135522 [details] [diff] [review]
patch

Concerning that typo: The pref is only used in one place:
http://lxr.mozilla.org/mozilla/source/layout/xul/base/src/nsTextBoxFrame.cpp#20
9
It's "access", not "acces". So it's a good thing to correct that.

Comment 14

15 years ago
Comment on attachment 135522 [details] [diff] [review]
patch

Pierre was faster.
Attachment #135522 - Attachment is obsolete: true

Comment 15

15 years ago
Created attachment 135562 [details] [diff] [review]
patch v.2: navigator-region and communicator-region

This is my first patch minus the issues Pierre already fixed.
It changes navigator-region and communicator-region to browser-region.
(Assignee)

Comment 16

15 years ago
thanks for help, Steffen.
Marking fixed !!!
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.