Closed Bug 221626 Opened 18 years ago Closed 18 years ago

Mozilla-specific report template

Categories

(Bugzilla :: User Interface, defect)

defect
Not set
normal

Tracking

()

RESOLVED FIXED
Bugzilla 2.16

People

(Reporter: rillian, Assigned: rillian)

Details

(Whiteboard: [fixed in 2.16.4])

Attachments

(1 file)

User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4) Gecko/20030930 Epiphany/1.0
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4) Gecko/20030930 Epiphany/1.0

reports/duplicates.html.tmpl mentions Mozilla specifically, which is an
inappropriate localization when bugzilla is used with other products. I
certainly took a year for anyone to notice it on bugs.ghostscript.com.

Reproducible: Always

Steps to Reproduce:
1. visit http://bugs.ghostscript.com/duplicates.cgi#explanation
2. notice the discrepancy with the data above :)




Expected Results:  
see example patch
According to Gervase Markham:

>> that template is intentionally Moz-specific in lots of places, and is marked
as such. It's officially in the tree as an "example" :-)

Resolving WONTFIX per Gerv's comments until our "example" policy changes.
Status: UNCONFIRMED → RESOLVED
Closed: 18 years ago
Resolution: --- → WONTFIX
Forgot to link to related bug report:

http://bugzilla.mozilla.org/show_bug.cgi?id=219659
Oops, just realised the UI owner is myk: if you disagree please reopen this.
OS: Linux → All
Hardware: PC → All
Gerv wasn't talking about the duplicates page, he was talking about the guided
enter bug form.  The duplicates page is part of the standard template set (it's
not an alternate format).
Status: RESOLVED → UNCONFIRMED
Resolution: WONTFIX → ---
confirming...
Status: UNCONFIRMED → NEW
Ever confirmed: true
Goes for HEAD and 2.16-branch. Justdave: please set target to 2.16 and give
approval for both.
Assignee: myk → rillian
<-- patch author
Status: NEW → ASSIGNED
OK, I discussed this with Myk, and it's only a cosmetic change, and we're doing
a release anyway, and neither of us sees a reason why not to. :)  Go ahead and
check it in on both branches.
Target Milestone: --- → Bugzilla 2.16
Whiteboard: [wanted for 2.16.4] [wanted for 2.17.5]
Turns out that the patch was invalid againest HEAD after all.

Checking in duplicates.html.tmpl;
/cvsroot/mozilla/webtools/bugzilla/template/en/default/reports/duplicates.html.tmpl,v
 <--  duplicates.html.tmpl
new revision: 1.4.2.3; previous revision: 1.4.2.2
done
Status: ASSIGNED → RESOLVED
Closed: 18 years ago18 years ago
Resolution: --- → FIXED
Whiteboard: [wanted for 2.16.4] [wanted for 2.17.5] → [fixed in 2.16.4]
The wording in the devel branch got fixed with:

http://bugzilla.mozilla.org/attachment.cgi?id=110936&action=view
QA Contact: matty_is_a_geek → default-qa
You need to log in before you can comment on or make changes to this bug.