On quitting, 'close all tabs' prompts appear for EVERY window

RESOLVED DUPLICATE of bug 220385

Status

SeaMonkey
Tabbed Browser
--
minor
RESOLVED DUPLICATE of bug 220385
15 years ago
10 years ago

People

(Reporter: Andrew W, Assigned: jag (Peter Annema))

Tracking

Trunk
PowerPC
Mac OS X

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.5) Gecko/20030925
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.5) Gecko/20030925

Close all tabs prompt works fine for individual windows.  When QUITTING, each
window gets prompted for 'do you want to close this'.  This is annoying.

Instead, there should be a single prompt:
"You have X tabs open in Y windows.  Are you sure you want to quit?"

Reproducible: Always

Steps to Reproduce:
Open two windows.  Open two tabs in each window.  Quit.

For real fun, open 7-8 windows and quit.  This tries your patience.
Actual Results:  
Each window prompted for 'closing with multiple tabs'.

Expected Results:  
A single prompt for all windows and tabs.

Comment 1

15 years ago

*** This bug has been marked as a duplicate of 220385 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
Product: Core → SeaMonkey
You need to log in before you can comment on or make changes to this bug.