Subscribe dialog doesn't remember its size and position

VERIFIED FIXED

Status

SeaMonkey
MailNews: Message Display
--
minor
VERIFIED FIXED
15 years ago
10 years ago

People

(Reporter: Stefan Borggraefe, Assigned: Stefan Borggraefe)

Tracking

({polish, regression})

Trunk
polish, regression

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment, 1 obsolete attachment)

974 bytes, patch
neil@parkwaycc.co.uk
: review+
Bienvenu
: superreview+
Details | Diff | Splinter Review
(Assignee)

Description

15 years ago
This is a regression, since this was fixed once per bug 60945. I don't know why
this doesn't work. The dialog subscribe.xul already contains 
persist="width height screenX screenY".
Probably because it lost its id="subscribeWindow" attribute.
(Assignee)

Comment 2

15 years ago
Taking.
Assignee: sspitzer → borggraefe
(Assignee)

Comment 3

15 years ago
Created attachment 132917 [details] [diff] [review]
Patch

I also changed the default initial window size so it is adaptive to the user's
font size.
(Assignee)

Updated

15 years ago
Attachment #132917 - Flags: review?(technutz)
(Assignee)

Updated

15 years ago
Attachment #132917 - Flags: review?(technutz) → review?(neil.parkwaycc.co.uk)

Comment 4

15 years ago
Comment on attachment 132917 [details] [diff] [review]
Patch

I quite fancy a width of 44em and height of 33em
(Assignee)

Updated

15 years ago
Attachment #132917 - Flags: review?(neil.parkwaycc.co.uk)
(Assignee)

Comment 5

15 years ago
Created attachment 132981 [details] [diff] [review]
Patch V1.1

Using the initial size Neil suggested.
Attachment #132917 - Attachment is obsolete: true
(Assignee)

Updated

15 years ago
Attachment #132981 - Flags: review?(neil.parkwaycc.co.uk)

Updated

15 years ago
Attachment #132981 - Flags: review?(neil.parkwaycc.co.uk) → review+
(Assignee)

Updated

15 years ago
Attachment #132981 - Flags: superreview?(bienvenu)

Updated

15 years ago
Attachment #132981 - Flags: superreview?(bienvenu) → superreview+
I took the liberty of landing this for you, Stefan, since you had r/sr all ready.

Hope you don't mind.

C:\moz_src\mozilla\mailnews\base\resources\content>cvs commit -m "Bug 221665.  S
ubscribe dialog doesn't remember its size and position.  Patch by Stefan Borggra
efe <borggraefe@despammed.com>.  r=neil, sr=bienvenu" subscribe.xul
Checking in subscribe.xul;
/cvsroot/mozilla/mailnews/base/resources/content/subscribe.xul,v  <--  subscribe
.xul
new revision: 1.95; previous revision: 1.94
done
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → FIXED
I landed this, but didn't code it, so I can verify that it's fixed with build
2004-05-12-08 on Windows XP with news.verizon.net
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey

Updated

10 years ago
Component: MailNews: Subscribe → MailNews: Message Display
QA Contact: stephend → search
You need to log in before you can comment on or make changes to this bug.