DHTML Counter on Panther Countdown page and scroll wheel cause the Countdown element to be painted above everything else

VERIFIED DUPLICATE of bug 162134

Status

()

Core
Plug-ins
VERIFIED DUPLICATE of bug 162134
14 years ago
13 years ago

People

(Reporter: Jamie Cho, Assigned: Peter Lubczynski)

Tracking

Trunk
PowerPC
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.5) Gecko/20030925
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.5) Gecko/20030925

Apple has a DHTML counter at http://www.apple.com/macosx/ to the release time of
its new OS. Moving the scrollwheel up and down with a mouse with a scroll wheel
detaches the DHTML from the window and seems to draw it in the root window. The
contents appear above everything else including menus.

Someone should look at this page before October 24, the release date for panther.

Reproducible: Always

Steps to Reproduce:
1. Open http://www.apple.com/macosx/ in Mozilla 1.5rc2
2. Use a mouse with a scrool wheel to scroll up and down until you see display
   problems.
3. Move the window around and note the position of the counter.
4. Pull down a drop menu such a Bookmarks and see what happens.

Actual Results:  
The counter that appears on http://www.apple.com/macosx/ seems to be detached
from the page.

Expected Results:  
The counter should remained attached to the page.

See http://homepage.mac.com/jamiec/oops.tiff
for an image.

Comment 1

14 years ago
This is actually not a DHTML counter but a QuickTime plugin. At least this is
what I see (or better, not see) in my mozilla and the source code:

<script language="Javascript" name="QUICKTIME OR NOT">
	<!--
		if (haveqt)
		{document.write('<object classid="clsid:02BF25D5-8C17-4B23-BC80-D3488ABDDC6B"
width="690" height="24"
codebase="http://www.apple.com/qtactivex/qtplugin.cab#version=6,0,2,0"><param
name="src"
value="http://a368.g.akamai.net/7/368/51/7586c05cb2f0d9/www.apple.com/macosx/images/indexcountdown10082003.mov"><param
name="AUTOPLAY" value="true"><param name="CONTROLLER" value="false"><param
name="TARGET" value="myself"><embed width="690" height="24" target="MYSELF"
src="http://a368.g.akamai.net/7/368/51/7586c05cb2f0d9/www.apple.com/macosx/images/indexcountdown10082003.mov"
pluginspage="http://www.apple.com/quicktime/download/index.html"
controller="false" autoplay="true"></object>');}
			else
		{document.write('<a
href="http://store.apple.com/1-800-MY-APPLE/WebObjects/AppleStore?productLearnMore=M9227LL/A"><img
src="http://a772.g.akamai.net/7/772/51/b92ab4e2197e9b/www.apple.com/macosx/images/indexcountdown10082003.gif"
alt="Get Panther" width="680" height="24" border="0"></a>');}
	// -->
</script>
Plug-ins.  If I recall correctly, the plug-in has to play nice; otherwise there
is no way to z-order it with other things....  I don't know whether quicktime
plays nice or not.
Assignee: roc → peterlubczynski-bugs
Component: Layout: View Rendering → Plug-ins

Comment 3

14 years ago

*** This bug has been marked as a duplicate of 162134 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.