Problem with CSS style entry overflow: auto causing poor rendering

RESOLVED INVALID

Status

()

RESOLVED INVALID
15 years ago
2 months ago

People

(Reporter: kphilp, Assigned: roc)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(2 attachments)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.5a) Gecko/20030728 Mozilla Firebird/0.6.1
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.5a) Gecko/20030728 Mozilla Firebird/0.6.1

The above page renders OK but if you download the page and the stylesheet
(www.cybercolloids.net/scripts/cybercolloids.css) and change the CSS body entry
to overflow: auto (its overflow: none at the moment) the page fails to render.
You just get a white page

Reproducible: Always

Steps to Reproduce:
1.Open www.cybercolloids.net, save as alocal file
2.Save www.cybercolloids.net/scripts/cybercolloids.css as a localfile
3.Remove the baseref in the html file
4.link the file to the local CSS
5.Alter the CSS body {overflow: none} entry to {overflow: auto}
6. Now the page fails to render
Actual Results:  
A white page, same with Mozilla 1.3

Expected Results:  
rendered the page, 

Konqueror works fine. The CSS and HTML validate on the WDG site wityh the
exception of the embed statement. removing this does not solve the problem
(Reporter)

Comment 1

15 years ago
Created attachment 132931 [details]
The CSS file
(Reporter)

Comment 2

15 years ago
Created attachment 132932 [details]
The HTML file
Can you reattach the testcase so that it actually works when I load the
attachment? The best thing to do would be to put the style in a <STYLE> block at
the start of the HTML and then attach the HTML with type text/html.
All the content inside the <body> is absolutely positioned, so the height of the
<body> is 0.  If you now do "overflow: auto", the <body> is overflowing, so we
hide the overflow, create scrollbars so you can scroll to it.... except the
scrollbars have to be 0px tall, since that's all the space you gave for them in
the <body>.
(Reporter)

Comment 5

15 years ago
Incorrect html coding in the first place. Not a valid bug. 
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → INVALID
Component: Layout: View Rendering → Layout: Web Painting
Product: Core → Core
You need to log in before you can comment on or make changes to this bug.