Newsgroup posts or messages sent by me should be "read" by default, as soon as they are downloaded from NNTP server.

RESOLVED WONTFIX

Status

--
enhancement
RESOLVED WONTFIX
15 years ago
11 years ago

People

(Reporter: davidgrant, Assigned: Bienvenu)

Tracking

Trunk
x86
Linux

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4) Gecko/20030808
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4) Gecko/20030808

Newsgroup posts or messages sent by me should be "read" by default, as soon as
they are downloaded from NNTP server.  Sometimes I have zero unread messages in
a certain newsgroup, then I write a message to that newsgroup.  Later on, I
noticed there is 1 unread message in that newsgroup, so I open that newsgroup
and look to see who had answered my post.  I then realize that no one has
replied to my post, and that the unread post was the message I sent myself.  Why
is this classified as unread?  Doesn't the act of writing that message involve
reading it simultaneously?

Reproducible: Always

Steps to Reproduce:
1. Compose a message in a newsgroup
2. Click on Send and Receive
3. Notice that your message has arrived in the newsgroup.
4. It is unread
5. Ask yourself, "why?"

Actual Results:  
The message that you just sent is unread.

Expected Results:  
The message that you just sent should be unread, just like when you send email
messages and they are set as "read" and moved to the Sent folder.

I hope this isn't a dupe, I couldn't find it by searching, and it was
challenging to think of keywords to search for this bug.

Comment 1

15 years ago
I vote wontfix. I want all my messages marked unread, so that I can easily use
them to find threads I've participated in, and any responses to my own messages.
(Reporter)

Comment 2

15 years ago
I vote that there should be a preference for this.  Even if it was just a hidden
preference in prefs.js that would be fine.

Comment 3

15 years ago
Why don't you all setup a filter to your taste?
Voting wontfix.

>Doesn't the act of writing that message involve
>reading it simultaneously?

No. it doesn't.

When client checks for number of unread posts it *does not* download the
headers, so there's no way to be sure that this 1 new post was just sent by you.
Product: MailNews → Core
This is an automated message, with ID "auto-resolve01".

This bug has had no comments for a long time. Statistically, we have found that
bug reports that have not been confirmed by a second user after three months are
highly unlikely to be the source of a fix to the code.

While your input is very important to us, our resources are limited and so we
are asking for your help in focussing our efforts. If you can still reproduce
this problem in the latest version of the product (see below for how to obtain a
copy) or, for feature requests, if it's not present in the latest version and
you still believe we should implement it, please visit the URL of this bug
(given at the top of this mail) and add a comment to that effect, giving more
reproduction information if you have it.

If it is not a problem any longer, you need take no action. If this bug is not
changed in any way in the next two weeks, it will be automatically resolved.
Thank you for your help in this matter.

The latest beta releases can be obtained from:
Firefox:     http://www.mozilla.org/projects/firefox/
Thunderbird: http://www.mozilla.org/products/thunderbird/releases/1.5beta1.html
Seamonkey:   http://www.mozilla.org/projects/seamonkey/
(Reporter)

Updated

13 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → WONTFIX
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.