When saving a page on local PC, the image was corrupted to the "cannot find default page".

RESOLVED WORKSFORME

Status

SeaMonkey
Composer
--
major
RESOLVED WORKSFORME
14 years ago
5 years ago

People

(Reporter: Hank, Unassigned)

Tracking

({dataloss})

Trunk
x86
Windows 2000
dataloss

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.5) Gecko/20030925
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.5) Gecko/20030925

When saving a page for the second time, composer replaces the images in the page
withe host's default cannot locate url message page. 

Reproducible: Always

Steps to Reproduce:
1.create a page on local PC, insert an image on the page
2.save the page and publich the page to th ehost site
3.edit the page again and save it again. - It is on this step that composes
replaces the page with the host's default 404 page.
Actual Results:  
my image was replace with the 404 page. 

Expected Results:  
Saved the picture. 

Seems like maintaining integrity of the web page is a major requirement for
Mozilla.
Well, your image are missing.

Where are your images?  in particular 
http://copland.udel.edu/~hankudel/editorbutton.gif

Where is it via URL?  Where is it in relation to your page?

Did you change the image when you updated the page?

Comment 2

14 years ago
Saving the complete page with trunk 2003100404 on Windows XP, i got: 

index.html (7kB)
index_files:
  editorbutton.gif (3kB)
  valid-html40.txt (3kB)

The only error i see is the erronous .txt extention. But it's a valid PNG file
that loads in Mozilla without renaming.
(Reporter)

Comment 3

14 years ago
I repeated the problem again see
http://copland.udel.edu/~hankudel/Bugzilla/index2.shtml 

note the picture labeled Bissingen Germany is missing. If you view PICT1072.jpg
you will see the 404 error message that was subsititued by Mozilla 

Comment 4

14 years ago
*** Bug 221522 has been marked as a duplicate of this bug. ***

Comment 5

14 years ago
I can't see that pic when i load that page. Mozilla isn't pulling it from your
cache like IE does.
(Reporter)

Comment 6

14 years ago
When saving a page I would expect Mozilla to save every thing I see rendered on
the screen - as is. Thus If I see a picture, then Mozilla would save that
picture without attempting to reload the picture from a URL. 
 

Comment 7

14 years ago
I believe the dataloss keyword should be added and therefore the severity raised
to critical.
(Reporter)

Updated

13 years ago
Keywords: dataloss
Product: Browser → Seamonkey

Comment 8

13 years ago
Perhaps somehow related to Bug 249508?

Comment 9

11 years ago
Dup of bug 120809 ?
Assignee: composer → nobody
QA Contact: composer

Comment 10

5 years ago
WFM here, no replacement.
PS: possible dup for Bug 266939...
User agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:16.0) Gecko/16.0 Firefox/16.0 SeaMonkey/2.13a1
Build identifier: 20120712003002
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.