View | Paragraph marks don't work for <br> tags

VERIFIED FIXED in Future

Status

()

P3
enhancement
VERIFIED FIXED
19 years ago
17 years ago

People

(Reporter: michael.j.lowe, Assigned: cmanske)

Tracking

({polish})

Trunk
Future
polish
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

19 years ago
Should include option on View menu to Show/Hide paragraph marks.
(Reporter)

Comment 1

19 years ago
This was part of 5.x classic, and should be part of the new 5.x.

Updated

19 years ago
Assignee: beppe → cmanske
Target Milestone: M14

Comment 2

19 years ago
assigning to cmanske
(Assignee)

Comment 3

19 years ago
Do we really need this? I'm guessing it is going to be very difficult. It will
require basic layout changes that will cause lots of headaches, since the
end-of-line character will have to become visible via generated content or
something, and we are having enough problems getting that to work with
named anchors.
Akkana and Mike: Do you agree?
(Assignee)

Updated

19 years ago
Status: NEW → ASSIGNED
Target Milestone: M14 → M15
(Reporter)

Comment 4

19 years ago
Please, please include it.   I presume generated content will also be needed for
bug #22262.    The road to a great product is never easy.   This is something
all word processors/ HTML editors should have - most already do.
(Reporter)

Comment 5

19 years ago
A CSS rule such as:

p:after,
address:after,
blockquote:after,
br:after,
h1:after,h2:after,h3:after,h4:after,h5:after,h6:after,
listing:after,
plaintext:after, xmp:after, pre:after,
li:after
{content: "\B6 ";}

added to EditorOverride.css, adds paragraph marks to the editor text - to an
extent.   I don't think it is possible to define a CSS rule which works for all
cases.   For example, how would you specify it for the paragraph marks embedded
in <PRE> </PRE> blocks?   CCing some CSS gurus to confirm this.
I can't think of any way to add paragraph marks to within a PRE other than hacking Layout.
(Assignee)

Comment 7

19 years ago
Thanks for the CSS, but it doesn't work for <br>, which, unfortunately, we
still need to use for paragraph delimiting.
(Assignee)

Comment 8

19 years ago
I'm still not convinced we need this. I don't see this supported in MS Word 97.
(Reporter)

Comment 9

19 years ago
It *is* supported in Word 97 - it has a prominant place on the standard toolbar 
(it is the paragraph symbol toolbar button).
(Assignee)

Comment 10

19 years ago
Don't worry! I have the css/js fix in my tree. We still have the problem of
not showing up for <br>
The problem with <br> is bug 2590. Adding dependencies.
Depends on: 2590
(Assignee)

Comment 12

19 years ago
Great! I'll checkin the code to load/unload an overlay style sheet just to 
turn on the paragraph marks sometime in the next couple of days.
(Assignee)

Comment 13

19 years ago
Checked in 3/30.
Note that the paragraph mark won't show up after our current "normal" paragraphs
because they are <br>s (see bug 2590)
Status: ASSIGNED → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → FIXED

Comment 14

19 years ago
verified in 4/3 build.
Status: RESOLVED → VERIFIED
(Assignee)

Comment 15

19 years ago
*** Bug 34469 has been marked as a duplicate of this bug. ***
(Assignee)

Comment 16

19 years ago
Let's use this bug to track the underlying problem, that <br> won't take
style (2590)
Status: VERIFIED → REOPENED
Resolution: FIXED → ---
Summary: Show/Hide Paragraph marks → View | Paragraph marks don't work for <br> tags
Target Milestone: M15 → M16
(Assignee)

Updated

19 years ago
Status: REOPENED → ASSIGNED
(Assignee)

Comment 17

19 years ago
Moving bugs to M17 to concentrate on features in M16
Target Milestone: M16 → M17
(Assignee)

Comment 18

19 years ago
2590 was marked as dup of 38370, so changing dependency.
Depends on: 38370
No longer depends on: 2590

Comment 19

19 years ago
setting to polish
Keywords: polish
Target Milestone: M17 → M19
(Assignee)

Updated

19 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 19 years ago19 years ago
Resolution: --- → FIXED
Target Milestone: M19 → Future
(Assignee)

Comment 20

19 years ago
We decided to remove the Paragraph marks feature, so this bug is irrelavant now.
We show paragraphs in the "Show All Tags" edit mode instead of showing the 
typical "paragraph character" at the end of a paragraph.

Comment 21

18 years ago
verified. i see Paragraph markers for paragraphs. looks good
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.