Mac OS X Help window deactivates menubar / can't be minimized / always on top

RESOLVED FIXED

Status

()

Core
XUL
--
major
RESOLVED FIXED
15 years ago
12 years ago

People

(Reporter: Dan M, Assigned: Josh Aas)

Tracking

Trunk
PowerPC
Mac OS X
Points:
---
Dependency tree / graph
Bug Flags:
blocking1.8.1 -

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

15 years ago
The Help window has no menubar, and on the Mac this means the menubar left over
from the previous window is still there and doesn't work. Worse, since the Help
window is alwaysRaised, the menubar can't be re-activated by raising a window
with an active menubar (say, a browser window).

Yes, this is bug 21296 but I'm breaking it out into its own bug because this
special case seems susceptible to hackery.

(This bug was split off from morpho-bug 135342, which will now be reduced to one
complaint.)
(Reporter)

Comment 1

15 years ago
Created attachment 133016 [details] [diff] [review]
hack to prevent windows lacking menubars from being alwaysRaised on the Mac
(Reporter)

Updated

15 years ago
Attachment #133016 - Flags: superreview?(sfraser)
Attachment #133016 - Flags: review?(pinkerton)
(Reporter)

Updated

15 years ago
Status: NEW → ASSIGNED
Target Milestone: --- → mozilla1.6alpha

Comment 2

15 years ago
<wail>Is there no other way?</wail>
(Reporter)

Comment 3

15 years ago
I'm glad you hate this. It's really quite awful. I can't think of anything
better, though. Even this is barely a solution.

Comment 4

14 years ago
*** Bug 232306 has been marked as a duplicate of this bug. ***

Updated

14 years ago
Blocks: 135342
Comment on attachment 133016 [details] [diff] [review]
hack to prevent windows lacking menubars from being alwaysRaised on the Mac

wow, i really don't like this either, but i'm also at a loss for what to do
about it.
Attachment #133016 - Flags: review?(pinkerton) → review+

Comment 6

14 years ago
*** Bug 237356 has been marked as a duplicate of this bug. ***
Summary: Mac OS X Help window deactivates menubar → Mac OS X Help window deactivates menubar / can't ne minimized / always on top
*** Bug 237355 has been marked as a duplicate of this bug. ***

Comment 8

13 years ago
I think this is resolved. The Help window is now backgroundable & minimizable.
The only remaining problem is the lack of a menu bar, which is a strict subcase
of bug 21296.
Summary: Mac OS X Help window deactivates menubar / can't ne minimized / always on top → Mac OS X Help window deactivates menubar / can't be minimized / always on top
Target Milestone: mozilla1.6alpha → ---
This is still an issue in Firefox (the help window is still always-raised)

Comment 10

13 years ago
Huh? I'm using Firefox 1.0 right now and the Help window is sitting politely in
the background.

Comment 11

13 years ago
(In reply to comment #10)
> Huh? I'm using Firefox 1.0 right now and the Help window is sitting politely in
> the background.

There is still a problem though it tried in trunk version Firefox. 
Is not patch reflected in trunk?

Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; ja-JP; rv:1.8b) Gecko/20050129
Firefox/1.0+
(Reporter)

Updated

13 years ago
Assignee: danm.moz → nobody
Status: ASSIGNED → NEW

Comment 12

13 years ago
When "Always on Top" is turned off by fix of bug251751, it is possible to
minimize it. 
251
Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; ja-JP; rv:1.8b2) Gecko/20050324
Firefox/1.0+

Updated

13 years ago
Assignee: nobody → joshmoz

Comment 13

13 years ago
*** Bug 316561 has been marked as a duplicate of this bug. ***

Comment 14

13 years ago
Nominating for 1.8.1 (or even earlier if possible).
Flags: blocking1.8.1?
Not going to minus, will take patch.
Flags: blocking1.8.1? → blocking1.8.1-
*** Bug 340965 has been marked as a duplicate of this bug. ***
(Assignee)

Updated

12 years ago
Attachment #133016 - Flags: superreview?(sfraser_bugs)
(Assignee)

Comment 17

12 years ago
The menu bar issue is taken care of by bug 355138. The situation is still messy in Firefox 2, but we're definitely not going to go in and try to fix that now.
Status: NEW → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → FIXED
(Assignee)

Comment 18

12 years ago
To make it clear, all issues have been resolved on the trunk afaik.
You need to log in before you can comment on or make changes to this bug.