Outbox / Send Later feature

RESOLVED DUPLICATE of bug 221818

Status

Thunderbird
Mail Window Front End
RESOLVED DUPLICATE of bug 221818
14 years ago
14 years ago

People

(Reporter: bart decrem, not checking bugmail, Assigned: Scott MacGregor)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
An automated way that mail sits in an Outbox until I hit a Send All button, and
that prompts me to send unsent mail when I quit Thunderbird.  Better yet, I'd
love the opportunity to just set an automatic timer so all my messages sit in
the Outbox for, say, 1 hour.   The reason I want this is that I send hundreds of
mails every day and once or twice a week, I make some horrendous mistake that I
realize within seconds after hitting Send - so I need a place where stuff sits
for a while, just in case I made a mistake. 

Example of an implementation: Entourage has Send Now and Send Later buttons in
the toolbar and a Send/Receive button.  If you press Send Later, mail sits in
the Outbox until the Send/Receive button gets pressed.  I believe Outlook has a
similar feature. 

This is different from: 
- The current File>Send Later feature because (1) it's impractical to go to
File>Send Later each time and (2) it's also impractical to have to remember to
send those messages at some later time (by going to File>Send Unsent Messages); 
- The Offline extension which (1) again, requires some intervention on my end
(going offline, then going online periodically and (2) doesn't seem to work for
me right now (using TB0.2): messages sit in my Unsent folder forever if I go
back online by clicking on Get Mail, even tho the preference says to deliver
Unsent messages when going online (I have to go to File>Send Unsent Messages to
deliver them). 

I have pledged $100 on Sourcesupport to get this feature implemented:
http://www.sourcesupport.org/?project=45

And there's a discussion on Mozillazine about this 
http://forums.mozillazine.org/viewtopic.php?t=24415 (4 people supporting the idea).
(Reporter)

Comment 1

14 years ago

*** This bug has been marked as a duplicate of 221818 ***
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.