IMAP fragments emails and attachments

RESOLVED WORKSFORME

Status

RESOLVED WORKSFORME
15 years ago
10 years ago

People

(Reporter: sholden, Assigned: Bienvenu)

Tracking

Trunk
x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; .NET CLR 1.1.4322)
Build Identifier: Mozilla/5.0 Windows; U; Windows NT 5.1; en-US; rv:1.3.1) Gecko/20030425

(This happens in Thunderbird 20030901 also)

I am using a network antivirus appliance to scan for email viruses.  It clears 
POP3, IMAP4, FTP and HTTP protocols from viruses it recognizes.  Using MS 
Outlook and IMAP4, the device clears viruses from my email.  When I use 
Mozilla or Thunderbird (important since everyone here uses Mozilla) the device 
does not see the viruses.  If I use Mozilla or Thunderbird and switch to POP3, 
the device does see the viruses and strips them out.

Top-tier support for the Vendor claims that it is because Mozilla is 
fragmenting the email and attachments when it downloads.  They say Outlook 
downloads the entire message when it uses IMAP so that's why it works there.

Reproducible: Always

Steps to Reproduce:
1. Configure Mozilla to use IMAP4
2. Download email with virus (or EICAR test pattern)
3. virus will get through the device
3. Change Mozilla to use POP3
4. Download email with virus (or EICAR test pattern)
5. Virus is caught at device


Expected Results:  
I expect Mozilla to not fragment email, if that is truly what it is doing.

Because this happens in Thunderbird and Mozilla, I am guessing that it is a 
fundamental aspect of the email program and will require too much effort to 
fix.  If you can fix it, you will be the wind beneath my wings.  But I would 
like to know technical details of what is happening.  It might be possible to 
get the vendor to add the ability to scan fragmented email, but I don't yet 
know.  Having some more information from the Mozilla group about this would be 
a big help.
(Assignee)

Comment 1

15 years ago
you can turn off this behaviour by turning off the
mail.server.servername.fetch_by_chunks preference for your imap server "serverName"
 (set it to false in prefs.js or using about.config)
(Assignee)

Comment 2

15 years ago
any luck with that pref? I'd like to close this bug...thx.
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Assignee)

Comment 3

15 years ago
resolving as wfm - with a few prefs, the reporter was able to get Mozilla to
work with the anti-virus appliance. These prefs, in fact:

user_pref("mail.imap.fetch_by_chunks", false);
user_pref("mail.imap.mime_parts_on_demand", false);
user_pref("mail.server.default.fetch_by_chunks", false);
user_pref("mail.server.default.mime_parts_on_demand", false);
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → WORKSFORME
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.