</script> in a string is erroneously parsed as an end of the script

VERIFIED DUPLICATE of bug 32618

Status

()

Core
JavaScript Engine
VERIFIED DUPLICATE of bug 32618
15 years ago
15 years ago

People

(Reporter: Filip Oscadal, Assigned: rogerl (gone))

Tracking

Trunk
x86
Windows 2000
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.5) Gecko/20030925
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.5) Gecko/20030925

produces a flase script ending, and a script crash

Reproducible: Always

Steps to Reproduce:
just check my script...


Expected Results:  
script crash

both in IE and Mozilla

Comment 1

15 years ago
That's not an error.  See the dup'ed bug.

*** This bug has been marked as a duplicate of 32618 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE

Comment 2

15 years ago
Verified Duplicate -

The moral is: the HTML parser sees the file before the JS parser does.
Compare bug 175375 -
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.