links in messages do not open browser

VERIFIED DUPLICATE of bug 247644

Status

VERIFIED DUPLICATE of bug 247644
15 years ago
13 years ago

People

(Reporter: assaflavie, Assigned: mscott)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.6a) Gecko/20031002 Firebird/0.7+
Build Identifier: ThunderBird/20031008 Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.6a) Gecko/20031002 Firebird/0.7+

when reading an HTML message in the preview pane and clicking on a link the
browser navigates to the link only if it is already open (the browser). If the
default browser is not running then nothing happens.

Reproducible: Always

Steps to Reproduce:
1. make sure the default browser isn't running.
2. read a message (HTML) in the preview pane.
3. click on an HTML link in the message.

Actual Results:  
nothing

Expected Results:  
a broswer window should open and navigate to the link destination.

very annoying.

Comment 1

15 years ago
I have the same problem.

Mozilla Thunderbird 0.3 (20031013)
* addressContext 0.3
* Offline Support
* QuickReply 0.4.1
* TagZilla 0.049
* Get All Messages [2003-04-21]

Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.5) Gecko/20031007
Firebird/0.7 StumbleUpon/1.89
* All-in-One Gestures 0.8.6
* Autohide Toolbox 0.7.1
* Download Statusbar 0.8a
* Flash Click to View
* IE View 0.6
* JavaScript Console Status 1.0
* Link Toolbar 0.6.1
* LiveHTTP Headers 
* TagZilla 0.049
* text/plain
* UserAgent Switcher 0.3
* Web Developer 0.4
* Work Offline
* Linky
* Help Viewer
* Link Visitor 030.20030908
* Session Saver 0.2
* Cute Menus 0.3
* jslib
(Assignee)

Comment 2

15 years ago
try re-setting your default browser as the default browser. 

For Firebird: Tools / Options / General / Make Default Browser

Comment 3

15 years ago
Thanks! 
That seemed to do it.

Why, though, did I not have a default browser handling links in TB?
(Assignee)

Comment 4

15 years ago
closing out the bug
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → WORKSFORME

Comment 5

14 years ago
I have the same problem. And if I open Firefox and make it check if it is the
default browser then it says that it already is the default browser. But the
links in Thunderbird still don't open Firefox if it isn't runing.
See bug 257228 which describes perhaps the same problem with current nightly
builds. 

Jure, can you confirm that this doesn't work with FF but with any other browser,
like SeaMonkey? Or do you have the problem with every browser?

Comment 7

14 years ago
*** Bug 251089 has been marked as a duplicate of this bug. ***
Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---
Cause this bug doesn't contain much information marking this one as dupe of bug
247644.

*** This bug has been marked as a duplicate of 247644 ***
Status: REOPENED → RESOLVED
Last Resolved: 15 years ago14 years ago
Resolution: --- → DUPLICATE
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.