upgrade from 1.5Rc2 to latest build stops mail retrieval

RESOLVED INVALID

Status

MailNews Core
Networking: POP
--
major
RESOLVED INVALID
14 years ago
9 years ago

People

(Reporter: Stef van der Made, Assigned: (not reading, please use seth@sspitzer.org instead))

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(2 attachments)

(Reporter)

Description

14 years ago
When I've completed an upgrade from 1.5-Rc2 to the latest build I can't retrieve
any mails anymore. The only way to fix this is delete the profile. Download
1.5-rc2 and start over only copying the mailbox files, adressbook file and
bookmarks.

Steps to reproduce

1 install Mozilla 1.5 rc2
2 copfigure and use it for a while creating a mail user profile using pop
3 upgrade to the latest build.
4 the profile gets corupt and mail retrieval is no longer possbile
and which file in your profile caused this problem ?

Comment 2

14 years ago
Stef, do you have more than one accounts? And if, did every accounts pop server
stop retieving mails?

What if you stay with the latest build and just create a new profile, create a
new account and try getting mails?
(Reporter)

Comment 3

14 years ago
I'm using a single account. The problem looks to be in the prefs.js file. I just
copied that file and the profile wen't bad again. Removing the prefs.js file and
recreating the mailbox fixes the file.

I'll have to try the second scenario. I'm not sure which option made the profile
go crazy last time as I'm now running 1.5rc2 again.
(Reporter)

Comment 4

14 years ago
The problem also seems to seep into the 1.5rc2 build as I've just seen to
problem occur again. I'll now setup a fresh account without any old stuff and
see if it happens again. It has taken since Oct13 to produce the problem again.
I'm hoping that it happens quicker this time as a clean profile with all the
settings that I had ain't fun to work with ;-)

Comment 5

14 years ago
What do you mean with "I can't retrieve any mails anymore"? What error do you get?
(Reporter)

Comment 6

14 years ago
I get the error can't connect with pop.planet.nl. While the server is available
(Reporter)

Comment 7

14 years ago
Created attachment 134202 [details]
Prefs.js file with corruption

When I use this preferences file I can't no longer retrieve email. When using
the preferences backup file I don't have any issues. The mozilla build is
20031025. I only used the build as mentioned before. So the problem seems to be
reproducable on my machine. The time to reproduce was less then a day.
(Reporter)

Comment 8

14 years ago
Created attachment 134203 [details]
prefs.js file without corruption

Prefs.js file that works OK

Comment 9

14 years ago
Ah, you've a proxy defined in your not working configuration.
Proxy is 10.0.0.149:3128 for each service - from http to ssl. Do you have such a
proxy in your system?

If not, remove these entries, resp. choose "Direct connection to the Internet".
Interesting is, that every entry has the same port - http and ftp are not problem?.
This is the problem : user_pref("network.proxy.socks", "10.0.0.149");

-> invalid
Please reopen if you are sure that you really have a socks proxy 
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → INVALID
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.