installer has no way to cancel once install starts

RESOLVED WONTFIX

Status

SeaMonkey
Installer
RESOLVED WONTFIX
18 years ago
9 years ago

People

(Reporter: Kathleen Brade, Unassigned)

Tracking

({helpwanted})

Trunk
helpwanted

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [need consensus])

(Reporter)

Description

18 years ago
Once the installation has started, I have no way to stop or cancel the
installation.  This really sucks (such as if I realize I'm installing in the
wrong place or the install is taking too long and I need to leave).

I would like to see the following:
 * a Cancel/Stop button
 * pressing [escape] key stop (or prompt if user really wants to stop?)
 * pressing command-. stop (or prompt as above)

Updated

18 years ago
Assignee: ssu → dveditz

Comment 1

18 years ago
This is the same for the Windows wizard installer.  It's actually to do with
xpinstall engine not offering a way to cancel the file installation process once
started via the wizard installer.

Reassigning to Dan for now.
This is similar to the XUL dialog cancel button issues Samir is working on, and
the issues are similar. The requirement that the wizards be able to cancel also
forces us to use the callback return value mechanism we discussed since that's
the only communication path between the wizards and the install engine.

But there are many problems. Our "install" is actually the installation of many
individual components so it's unclear what should happen if you cancel in the
middle and all the options are bad.

Clearly we can easily stop installing the component we're in the middle of and
any further components, but what about components we've already installed?
Options include

leave them -- if this is an upgrade then the old components not upgraded might
clash with the new ones. You don't really believe our XPCOM/compatibility story
do you?

Uninstall them -- Uninstall isn't working right now, but when it is AND
assuming we expose it to the wizards then I guess on a fresh install we could
do the uninstall. On an upgrade this would screw us because uninstall is just
that, not a "revert to previous version".

We have brainstormed in the past that having a revert feature (assuming the
user can spare the diskspace) might be nice, but I can't see it happening for
5.0. Without that feature implementing a cancel is really problematic.
Target Milestone: M17
Post beta if at all. We have some structural issues that prevent this at the
moment.
Status: NEW → ASSIGNED

Updated

18 years ago
Blocks: 32500

Comment 4

18 years ago
We don't plan to address this issue in this release.
Target Milestone: M17 → M30

Comment 5

18 years ago
*** Bug 32500 has been marked as a duplicate of this bug. ***
Changing fictional "M30" to reality
Target Milestone: M30 → Future

Comment 7

17 years ago
updating mac mozilla installer QA contact to me
QA Contact: gbush → asa

Comment 8

17 years ago
fwiw: I personally hate rollbacks [MSI does this: clicking cancel in an install 
undoes the entire install].

If you do choose some route like that how about:

<Dialog>
<title>Abort Install</title>
<listbox>
Checkbox: Checked=installed, Gray=partially installed, Unchecked=not installed
Text: Component Name
</listbox>
Quiting now will remove any partially installed components.
You can check or uncheck components to cause them to be installed or 
uninstalled if you click finish.
<button value="quit"/><button value="finish"/>
</dialog>

From this dialog, quiting should cause the quit path to execute (remove the 
incomplete component)
-

Personally I don't see why we need to have separate component selection and 
installation sections.

If we did that, the user could click <button value="pause"/> and then change 
the settings.
checked items that are not installed would be bolded.
unchecked items that are installed would be italicized.
Anything deselected would be removed before continuing to install when the user 
clicks the <button value="continue"/> which replaced the pause button.
Keywords: helpwanted, ui
Whiteboard: [need consensus]

Comment 9

17 years ago
Simplest solution is to label the button 'Stop' not cancel and put up a 
confirmation dialog explaining that if you stop now you're likely to be left with 
broken software. Yes its horrible and it will scare the bejesus out of users but 
its better than labelling the button Cancel and pretending its all OK if its not.

That said, for an install (i.e. a first time install not an upgrade) we really 
should be able to do cancel. Moz installs very few files outside of the Mozilla 
Folder, so full uninstall is not really needed. Just nuke the folder and the 
registry and whatever other junk - :-) - goes into the netscape version.

Upgrades are much harder, as you need proper undo not just uninstall, since you 
have to be able to get the old components back. Some MS apps do this, but of 
course one must check for disk space and present the fact that the undo will not 
work to the user if there isn't enough disk space to attempt it. In the short 
term, no cancel button for upgrades is again preferable to having it and having 
it not work right. 

Comment 10

16 years ago
this is bad, can we try to make a decision w/in a week?
Status: ASSIGNED → NEW
QA Contact: asa → bugzilla
Target Milestone: Future → ---

Comment 11

16 years ago
windows version of this bug is bug 22194
QA Contact: bugzilla → ktrina

Comment 12

16 years ago
We can't make this decision in a week. This bug's been open for 2+years with no
solution imminent. Is there some reason we need a decision so quickly? I think
the best course of action is to check with the installer team and see if there's
been any technical progress on the uninstall/revert scene and then discuss the
best solution considering the tradeoffs. Some installers change the button name
from Cancel to Stop to indicate the state the current install is in (e.g. can go
back to the beginning, can't undo progress to date, but can stop at this point
with funky results, etc). Then we can target this at the next viable release. 

Comment 13

16 years ago
could we change this bug to be "all platforms" since this bug is also seen on win32
OS: Mac System 8.5 → All
Hardware: Macintosh → All
Product: Browser → Seamonkey
Assignee: dveditz → nobody
Priority: P3 → --
QA Contact: ktrina → general
Seamonkey and Firefox are using a new NSIS based installer. resolving this old bug, please reopen if you still get this with the new installer
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.