Closed Bug 221957 Opened 18 years ago Closed 18 years ago

background-attachment:fixed in td:hover effectively disables onclick event

Categories

(Core :: DOM: UI Events & Focus Handling, defect)

x86
Linux
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 102578

People

(Reporter: jast, Unassigned)

References

()

Details

(Keywords: testcase)

Attachments

(1 file, 1 obsolete file)

2.01 KB, text/html
Details
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.5a) Gecko/20030728 Mozilla Firebird/0.6.1
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.5a) Gecko/20030728 Mozilla Firebird/0.6.1

Table cells that are set by CSS to change their background to something else
with "background-attachment" set to "fixed" for the new background become
unclickable in Mozilla. Not only will onClick handlers be ignored, but links
within those table cells will no longer be clickable either; they don't even
become focused when clicked (they can still be activated by focusing them using
the keyboard and pressing Enter, though).

The bug occurs for all elements which have "display" set to "table-cell", e.g. <td>.

Reproducible: Always

Steps to Reproduce:
Attached file testcase (obsolete) —
Testcase works for me 20031010 PC/WinXP
Keywords: testcase
Jan, please test something like a current build.  The build you are testing is
VERY old.
Attached file fixed testcase
Tested again with 2003101222, Linux. Bug occurs in my own testcase but not in
the one attached by Bill since that one is faulty: it uses
"background-position" where it should use "background-attachment".
"background-position" doesn't seem to matter for this bug.

I've uploaded my own testcase (identical with the one pointed to by the "URL"
field), with two different flavours now: there are the usual cells with an
initially non-fixed background, and a cell with an initially fixed background.
Interestingly, the latter variant doesn't trigger the bug.
Comment on attachment 133164 [details]
testcase

See what happens when I write testcases in the middle of the night.

The new testcase, however, stills works for me in every test.
Attachment #133164 - Attachment is obsolete: true
Apologies... I have tested it on Windows 2000, using 2003101304 and Firebird
20031008, they don't seem to be affected. Next time I won't make early
assumptions about the affected platforms.
However, all my tests using Linux confirmed the bug, so my guess is that it's a
general issue with Linux builds.
OS: All → Linux
Jan, the testcases work for me with linux build 2003-10-07-22...  What
windowmanager are you using?  Does the bug appear with all windowmanagers?
I guess this is the point where I have to slap myself. I didn't stop to think
trying other window managers, it works just fine with twm. My problem was
occuring with Fluxbox 0.1.14. I don't have another blackbox clone (or any other
window manager whatsoever) at hand to try, though.
I'm just curious how the window manager could affect the events of Mozilla,
especially since it only seems to affect them in this very specific case.
let me note that I could reproduce this bug using metacity as window manager
Probably bug 102578 if fluxbox and metacity are showing it while twm and
Afterstep (what I have here) are not... biesi, does applying the gtk1 patch in
that bug fix the problem for you?

Marking dependent for now.
Depends on: 102578
hm... this works in a gtk2 build (still metacity). the patch on bug 102578
didn't seem to have an effect on this testcase with my gtk1 build, though.
gtk build after checkin for 102578 (2003111709) makes both rows behave the same
way (first two cells pop a JScript dialog offering thanks for the click and the
cell backgrounds change on mouse over, the input field switches text to "Thanks").

This issue seems resolved by 102578.

*** This bug has been marked as a duplicate of 102578 ***
Status: UNCONFIRMED → RESOLVED
Closed: 18 years ago
Resolution: --- → DUPLICATE
Component: Event Handling → User events and focus handling
You need to log in before you can comment on or make changes to this bug.