Mozilla hangs if localhost port 16001 is filtered

RESOLVED DUPLICATE of bug 191580

Status

SeaMonkey
Find In Page
RESOLVED DUPLICATE of bug 191580
15 years ago
10 years ago

People

(Reporter: jnurmi-bugzilla, Assigned: Aaron Leventhal)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4) Gecko/20031010 Debian/1.4-6
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4) Gecko/20031010 Debian/1.4-6

If iptables (and presumably ipfw/ipchains/etc) are configured to block / filter
port 16001 (even when mozdsp is set to something other than auto or ESD),
mozilla hangs indefinately upon keystroke.  Mousing will work fine, so long as
no keys are pressed.

Reproducible: Always

Steps to Reproduce:
1. iptables -I INPUT -p tcp --dport 16001 -j DROP
2. start mozilla
3. type Ctrl-L to enter a URL
4. try to enter said URL

Actual Results:  
mozilla hangs for an indefinate (possibly infinite, but definately > 30 seconds)
period of time)

Expected Results:  
the attempt to hook to ESD should not be done with MOZDSP set, and even if it
does try to do it, the sound should be scheduled to play on completion (should
it succeed), or simply be dropped untill the sound daemon of choice is located.

I am an iptables junky, so the only fix Ive used (to work around the -P DROP) is
to do an iptables -A INPUT -p tcp --dport 16001 -i lo -j REJECT.  which not
harmful, is bloody irritating, and a tough nut to crack
This is an nsSound issue from typeahead find -- nothing to do with bookmarks.
Assignee: p_ch → aaronlev5
Component: Bookmarks → Keyboard: Find as you Type
QA Contact: sairuh

Comment 2

14 years ago
(In reply to comment #1)
> This is an nsSound issue from typeahead find -- nothing to do with bookmarks.

Can you please explain the nsSound issue with typeahead find?  I've had problems
with type-ahead-find locking up netscape when I type a keyword phrase that
doesn't exist, and if it's related to sound, I'd like to patch it in my user
prefs.  

Is there a known workaround? 
(Assignee)

Comment 3

14 years ago
I thought the typeahead sound was defaulted to off for Linux.

user_pref("accessibility.typeaheadfind.enablesound", false); 

See docs at http://www.mozilla.org/projects/ui/accessibility/typeaheadfind.html

Comment 4

14 years ago

*** This bug has been marked as a duplicate of 191580 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
Product: Core → SeaMonkey
You need to log in before you can comment on or make changes to this bug.