Closed Bug 222016 Opened 17 years ago Closed 17 years ago

Provide capability for handheld to overwrite the desktop or desktop to handheld

Categories

(MailNews Core Graveyard :: Palm Sync, enhancement)

enhancement
Not set
normal

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: raccettura, Assigned: Bienvenu)

References

Details

Attachments

(1 file)

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.5) Gecko/20030925
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.5) Gecko/20030925

Standard Palm Desktop Conduits allow the user to select between 3 modes:

1.  Sync (already implemented)
2.  Handheld overwrites desktop
3.  Desktop overwrites handheld

2 & 3 are not implemented with Palm Sync on SeaMonkey, and won't make initial
builds for Thunderbird.

The conduit should be enhanced to provide this functionality.

It is good for the user, as a mistake on either end could be catastrophic for
the data.  The ability to overwrite gives the user final say on how the sync
should be conducted.  

Reproducible: Always

Steps to Reproduce:
Status: UNCONFIRMED → NEW
Ever confirmed: true
*** Bug 227207 has been marked as a duplicate of this bug. ***
Blocks: 227205
taking. Is this only in the case of conflicts between updates on the desktop and
updates on the palm, or does it say we only do a one-way sync? The Palm
documentation implies it's just a one-way sync so that's what I'm going to
assume for now.
Assignee: cavin → bienvenu
It's one way sync.  Override all.

So I can perform a "backup" either way, rather than a "sync".
taking off the m4 list
No longer blocks: 227205
Attached patch proposed fixSplinter Review
this patch needs some more testing, but it seems to work
Blocks: 230700
David,

If you would like help testing, just let me know.  I'm not setup here to compile
yet, so I will need a binary.
fix checked in. If you can get palmsync from a daily windows mozilla build, you
can test it that way. Otherwise, I'll have to build an xpi.
Status: NEW → RESOLVED
Closed: 17 years ago
Resolution: --- → FIXED
Unless it's uber-important that tests be against the trunk, I'd perfer to go
test on 1.6 with an XPI if you have one, since it's stable,and I use it full
time.  I'd perfer testing in a real-life setting (rather than try a few times
with test data).

But either way, need some testing, just let me know.
Unfortunately, it needs to be tested against the trunk. I made some
corresponding changes to the AB code that are required.
Alright.  I'll give it a spin with tomorrow morning's build and let you know how
it goes.
OK, thx. Please be careful with your data :-)
Always am.  I know Palm Sync is an awkward creature.
*** Bug 190034 has been marked as a duplicate of this bug. ***
Per conversation with David:

Default should be sync.  Appears as "Handheld overwrites Desktop".


Address Field #1 not carried (more likely a result of Bug 226221)
Product: MailNews → Core
*** Bug 182431 has been marked as a duplicate of this bug. ***
Product: Core → MailNews Core
Product: MailNews Core → MailNews Core Graveyard
You need to log in before you can comment on or make changes to this bug.