Mozilla uninstalls hangs if Netscape 7.x is running

RESOLVED WORKSFORME

Status

SeaMonkey
Installer
RESOLVED WORKSFORME
14 years ago
9 years ago

People

(Reporter: Patrick, Unassigned)

Tracking

Trunk
x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.6a) Gecko/20031013
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.6a) Gecko/20031013

I think this one is very similar to bug 132858 but not quite.

Run Netscape 7.1 with profile A, different from you regular Mozilla profile.

Using the Windows Control Panel, try to uninstall a recent Mozilla trunk build.
The Mozilla Installer says it can't continue but it has detected Netscp.exe is
running. 

It gives you the option to shut down Netscape and continue. 
Maybe this is a won't fix, but my guess is that as long as any profile is locked
Mozilla won't uninstall and that the uninstaller is not able to tell a Mozilla
lock from a Netscape lock.

Reproducible: Always

Steps to Reproduce:
1. Run Netscape 7.1 with profile A
2. Fully shutdown Mozilla nightly that uses profile B
3. Try to uninstall Mozilla from the Windows Control Panel


Actual Results:  
Warning pop-ups that Netscape needs to be shutdown for Mozilla uninstall to continue

Expected Results:  
Uninstalled Mozilla while leaving Netscape running

This could cause data loss in case Netscape 7 is used to compose a mail or a web
page.

Comment 1

14 years ago
*** Bug 254028 has been marked as a duplicate of this bug. ***

Comment 2

14 years ago
I'm seeing this with Firefox too. But not hanging, just have to okay the close
Netscape dialogs to continue with uninstall.
Product: Browser → Seamonkey

Updated

12 years ago
QA Contact: bugzilla → general
Seamonkey and Firefox are using a new NSIS based installer. resolving this old bug, please reopen if you still get this with the new installer
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.