mail compose window zlevel is unconstrained

VERIFIED INVALID

Status

SeaMonkey
MailNews: Message Display
VERIFIED INVALID
15 years ago
14 years ago

People

(Reporter: Dan M, Assigned: Dan M)

Tracking

Trunk
x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

(Assignee)

Description

15 years ago
The Mail Compose window, with a normal z-level, is allowed to drop behind an
alwaysLowered browser window. (Bad).

Current trunk build.
0) Install the window z-level altering extension from bug 42557.
   (Heh. A little bit of advertising, there.)
1) Launch Mozilla (I'm assuming it opens a browser window by default).
2) Set the browser window's level to "lowered."
3) Open the Mail & Newsgroups window.
4) Open a new Message window.
5) Close the Message window from step 4.
6) Open another "new" Message window.
   (operational note: it's really the same window).
7) Mouseclick the browser window.
   -- the Message window is sent behind the browser window.

This may be related in some way to bug 204761 (which I can't reproduce). This
bug, though, is specific to the Mail Compose window. That window isn't actually
deleted when it's "closed"; it's only hidden. This bug is related to the Compose
window's unique close/reopen methodology.
(Assignee)

Comment 1

15 years ago
cripes. user error or something. this is bug 222042.
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → INVALID

Comment 2

15 years ago
ver
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.