www.danskebank.dk - bad javascript; layers don't work

VERIFIED FIXED

Status

VERIFIED FIXED
15 years ago
4 years ago

People

(Reporter: nielslynge, Unassigned)

Tracking

({ecommerce})

Details

(URL)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.5a) Gecko/20030728 Mozilla Firebird/0.6.1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.5a) Gecko/20030728 Mozilla Firebird/0.6.1

Hi www.danskebank.dk is the biggest bank in denmark, it would help a lot of
people if mozilla was showing the page correct please take 1 second to view the
page in mozilla and in iexplorer.

in explorer the logon and so on has a dropdownbox.
But it dos'nt in mozilla, and its almost imposible to read the text

Reproducible: Always

Steps to Reproduce:
1.
2.
3.



Expected Results:  
handled the way iexporer does

Comment 1

15 years ago
The JavaScript console shows errors for the page, so I guess this is not
Mozillas fault.  Should this be Tech Evangelism?

Updated

15 years ago
Keywords: ecommerce

Comment 2

15 years ago
Yeah, it's Tech. Evang.

The site's using (comments mine)
 	if(document.all){            //for IE
		mouseY = event.clientY;
		mouseX = event.clientX;
	}
	else if(document.layers){    //for old NS
		mouseY = e.pageY;
		mouseX = e.pageX;
	}	
to define mouseX, which is needed later on in the page, but NEITHER of
document.all or document.layers is correct javascript. Same thing goes for a
variable named dMenu, which is apparently used to make a popup menu.

I don't recognize the language so I'm not going to do anything to the bug since
I don't know where to send it. Someone else will have to do that.

Also note that there's a meta-bug for banks, this should be added as a blocker
for that. And I didn't check, maybe this is a dupe? 

Comment 3

15 years ago
Denmark. Danish. I knew that.

Updating the summary to something more descriptive, adding it as blocker (since
it wasn't a dupe), etc. 
Blocks: 124594
Status: UNCONFIRMED → NEW
Component: Layout: Form Controls → Other
Ever confirmed: true
OS: Windows 2000 → All
Product: Browser → Tech Evangelism
Hardware: PC → All
Summary: Grafic is displayed wrong → www.danskebank.dk - bad javascript; layers don't work
Version: Trunk → unspecified
(Reporter)

Comment 4

15 years ago
www.danskebank.com to get the site in english... :)


r3778web@danskebank.dk

Contact us   
    
 
24 hours a day, 7 days a week, 365 days of the year

You can call us any time you need some advice or want to check your balance 
(customers in Denmark).

Our telephone number is +45 33 44 00 00

E-mail
If you want to contact us by e-mail, 
please use our general address.

You can use this address for questions about products and services - both 
technical and general matters. You can also send feedback about our services 
and our site.

 

Comment 5

15 years ago
->Default owner
Assignee: form → other
QA Contact: ian → other

Comment 6

15 years ago
move to new danish component
Component: Other → Danish

Comment 7

14 years ago
menu dropdowns look fixed.
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → FIXED

Comment 8

14 years ago
Looked through the source and it looks fixed to me.
Status: RESOLVED → VERIFIED
Product: Tech Evangelism → Tech Evangelism Graveyard
You need to log in before you can comment on or make changes to this bug.