Crash in JS GC when closing View Source window

CLOSED DUPLICATE of bug 1264

Status

()

Core
DOM
P2
normal
CLOSED DUPLICATE of bug 1264
19 years ago
17 years ago

People

(Reporter: Peter Linss, Assigned: vidur (gone))

Tracking

Trunk
x86
Windows 98
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

19 years ago
Load above URL, open view source window, click on view source close box, crash.

Here's the stack trace (only tested on Win98)

KERNEL32! bff768a4()
gc_root_marker(JSHashEntry * 0x01207590, int 4, void * 0x01052220) line 599 + 35
bytes
JS_HashTableEnumerateEntries(JSHashTable * 0x011db230, int (JSHashEntry *, int,
void *)* 0x0051169e gc_root_marker(JSHashEntry *, int, void *), void *
0x01052220) line 347 + 15 bytes
js_GC(JSContext * 0x0125e900) line 717 + 21 bytes
js_ForceGC(JSContext * 0x0125e900) line 614 + 9 bytes
JS_GC(JSContext * 0x0125e900) line 431 + 2559 bytes
nsJSContext::GC(nsJSContext * const 0x0125e8c0) line 241 + 13 bytes
GlobalWindowImpl::SetNewDocument(GlobalWindowImpl * const 0x0125e854,
nsIDOMDocument * 0x00000000) line 217
DocumentViewerImpl::~DocumentViewerImpl() line 198
DocumentViewerImpl::`scalar deleting destructor'(unsigned int 1) + 15 bytes
DocumentViewerImpl::Release(DocumentViewerImpl * const 0x0121c580) line 156 + 99
bytes
nsWebShell::Destroy(nsWebShell * const 0x0121c2e0) line 760 + 27 bytes
nsBrowserWindow::Close(nsBrowserWindow * const 0x0121c9e0) line 1593
HandleBrowserEvent(nsGUIEvent * 0x00b1f518) line 304
nsWindow::DispatchEvent(nsWindow * const 0x0121cd30, nsGUIEvent * 0x00b1f518,
nsEventStatus & nsEventStatus_eIgnore) line 355 + 10 bytes
nsWindow::DispatchWindowEvent(nsGUIEvent * 0x00b1f518) line 371
nsWindow::DispatchStandardEvent(unsigned int 101) line 386 + 15 bytes
nsWindow::OnDestroy() line 1683
nsWindow::ProcessMessage(unsigned int 2, unsigned int 0, long 0, long *
0x00b1f644) line 1337
nsWindow::WindowProc(void * 0x00000ad8, unsigned int 2, unsigned int 0, long 0)
line 414 + 27 bytes
KERNEL32! bff7363b()
KERNEL32! bff942e7()

Comment 1

19 years ago
Setting all current Open/Normal to M4.

Comment 2

19 years ago
per leger, assigning QA contacts to all open bugs without QA contacts according
to list at http://bugzilla.mozilla.org/describecomponents.cgi?product=Browser

Updated

19 years ago
QA Contact: 4015 → 4616

Comment 3

19 years ago
QA contact re-assigned according to the product areas we're currently working
on.
(Assignee)

Updated

19 years ago
Status: NEW → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → DUPLICATE
(Assignee)

Comment 4

19 years ago
*** This bug has been marked as a duplicate of 1264 ***

Updated

19 years ago
Status: RESOLVED → CLOSED

Comment 5

19 years ago
Closing this bug since its duplicate of bug 1264
You need to log in before you can comment on or make changes to this bug.