Easy to use file-open from command line (like galeon -w myfile.html)

RESOLVED DUPLICATE of bug 120467

Status

()

--
enhancement
RESOLVED DUPLICATE of bug 120467
15 years ago
15 years ago

People

(Reporter: Marcin.Kasperski, Assigned: bugzilla)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.5a) Gecko/20030728 Mozilla Firebird/0.6.1
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.5a) Gecko/20030728 Mozilla Firebird/0.6.1

After switching from galeon to Firebird I miss the ability to open the file
within the running browser using command like
     galeon -w myfile.html
     galeon -w docs/index.html
etc.
The problem has two parts in Firebird

1) No clean equivalent to -w option (open in existing browser or start 
   the new one if there is no such)

One can workaround it writing scripts like 
  #!/bin/sh
  MOZILLA=/usr/local/bin/MozillaFirebird
  $MOZILLA -remote "ping()" &&
  $MOZILLA -remote "openURL($@, new-window)" &&
  exit 0
  #if we're here, open a new process.
  $MOZILLA "$@"
but the problem is so frequent that one could integrate the solution into
mozilla. Especially considering the fact, that mozilla presents very stupid
dialog-box while the second instance is being started.


2) No local paths handling

Running command like 
   MozillaFirebird myfile.html
results in opening some web address a bit similar to the file name. To get the
expected reply one need to write
   MozillaFirebird file://`pwd`/myfile.html
what is far harder to write. 


Reproducible: Always

Steps to Reproduce:
1. Create or find some html file on your drive
2. Try opening it using
      MozillaFirebird test.html
3. Keep the previous mozilla running and try 
      MozillaFirebird test2.html

Actual Results:  
2. Mozilla reported that http://www.test.html does not exist
3. Mozilla asked me which profile I want (???)

Expected Results:  
Open the files given. Both in the same instance.

Comment 1

15 years ago
The first issue is a dupe of bug 122698, the second issue is a dupe of bug 120467.
Also this may be marked INVALID because two issues are reported in one bug.
magic eight ball says: dupe against file handling (120467)  (might as well dupe
it, rather than INVALID it and prompt to file two separate bugs, which would
then be duped :)

*** This bug has been marked as a duplicate of 120467 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
QA Contact: mpconnor
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.