If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

High-ASCII characters are rendered invisible when using UTF-8

RESOLVED DUPLICATE of bug 222271

Status

Thunderbird
Mail Window Front End
RESOLVED DUPLICATE of bug 222271
14 years ago
14 years ago

People

(Reporter: David Oftedal, Assigned: Scott MacGregor)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.5a) Gecko/20031012 Mozilla Firebird/0.6.1
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.5a) Gecko/20031012 Mozilla Firebird/0.6.1

When entering a high-ASCII character such as æøåÆØÅäÄöÖüÜÛüñÑ with the encoding
set to UTF-8, the characters are rendered invisible. This does not happen with
the encoding set to iso-8859-1, and is therefore most likely a font problem.

Reproducible: Always

Steps to Reproduce:
1. Go to a form text area.
2. Set the page encoding to UTF-8.
3. Type away and watch high ascii chars be rendered as blank space.

Actual Results:  
The characters: æøåÆØÅäÄöÖüÜÛüñÑ are rendered as "                ".

Expected Results:  
Rendered them as æøåÆØÅäÄöÖüÜÛüñÑ.

I'm using the XFT version. The same bug appears in Thunderbird.
(Reporter)

Comment 1

14 years ago
For Firebird, this is resolved by amending the default font settings.
Not so fo Thunderbird, though.
moving to Thunderbird per comment 1
Component: General → Mail Window Front End
Product: Firebird → Thunderbird

Updated

14 years ago
Assignee: blake → mscott
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 3

14 years ago

*** This bug has been marked as a duplicate of 222271 ***
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.