URL Manager Pro menu doesn't work

RESOLVED WONTFIX

Status

()

Firefox
Bookmarks & History
--
major
RESOLVED WONTFIX
15 years ago
12 years ago

People

(Reporter: Lee, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.6a) Gecko/20031011 Firebird/0.7+
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.6a) Gecko/20031011 Firebird/0.7+

Does not work properly with URL Manager Pro. URL Manager Pro works the same with
Safari and Internet explorer. With Firebird the URL Manager Ikon shows in the
top bar, but selecting a bookmark results in never ending wheel below arrow
rotation and no results

Reproducible: Always

Steps to Reproduce:
1. I always have URL Manager pro lauched.
2. Launch Safari or IE or Firebird and get rectangular Ikon of URL Manager in
top bar.
3. Use this Ikon & works ok with Safari or IE, but Firebird gives one a whirling
dervish below an arrow.

Actual Results:  
Works fine with IE or Safari but not Firebird

Expected Results:  
Should have connected to the bookmark chosen with URL Manager Pro.
Is this a problem with SeaMonkey?  If not, please move this to the Firebird
product where it belongs.

Comment 2

15 years ago
Support for URL Manager Pro is present in Seamonkey since bug 56589 (oct 2002).
The MenuSharing library in initialized at
http://lxr.mozilla.org/seamonkey/source/widget/src/mac/nsMacMessagePump.cpp#238
,  but it's only compiled for Carbon. Does this mean that it doesn't work
anymore in Macho-Seamonkey (and Firebird) ?

On the other hand, http://url-manager.com/faq.html mentions that you'll need URL
Manager Pro 3.1, and this is still in development. To work with applications
that don't support Shared Menus, you'll need Shared Menus Enhancer (
http://www.url-manager.com/sme.html ), and that should work for Mozilla.
Reporter are you using SME ?
Product: Browser → Seamonkey

Updated

13 years ago
Assignee: general → firefox
Component: General → General
Product: Mozilla Application Suite → Firefox
QA Contact: general → general
Summary: Does not work properly with URL Manager Pro. URL Manager Pro works the same with Safari and Internet explorer. With Firebird the URL Manager Ikon shows in the top bar, but selecting a bookmark results in never ending wheel rotation. → Does not work properly with URL Manager Pro. URL Manager Pro works the same with Safari and Internet explorer. With Firebird the URL Manager icon shows in the top bar, but selecting a bookmark results in never ending wheel rotation.
Version: Trunk → unspecified

Comment 3

13 years ago
Moving to bookmarks...
Assignee: firefox → vladimir+bm
Component: General → Bookmarks
QA Contact: general → mconnor

Comment 4

13 years ago
Lee, could you please try to re-test this bug using a more recent build, preferalbly one of the nightly 
builds found in the dev section of mozilla.org?

Updated

13 years ago
Summary: Does not work properly with URL Manager Pro. URL Manager Pro works the same with Safari and Internet explorer. With Firebird the URL Manager icon shows in the top bar, but selecting a bookmark results in never ending wheel rotation. → problem with URL Manager Pro menu

Updated

13 years ago
Summary: problem with URL Manager Pro menu → URL Manager Pro menu doesn't work
Assignee: vladimir+bm → nobody

Comment 5

13 years ago
http://url-manager.com/faq.html claims that it works with URL Manager Pro 3.1 and Shared Menus Enhancer.

Marking as WONTFIX. WORKSFORME would be ok too, but then I would have to download and test both URL Manager Pro and Shared Menus Enhancer. Reporter, please reopen if you don't agree.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → WONTFIX
sorry for bugspam, long-overdue mass reassign of ancient QA contact bugs, filter on "beltznerLovesGoats" to get rid of this mass change
QA Contact: mconnor → bookmarks
You need to log in before you can comment on or make changes to this bug.