Cooper Black along with mixture of fonts makes Firebird page look unprofessional

RESOLVED FIXED

Status

www.mozilla.org
General
RESOLVED FIXED
15 years ago
6 years ago

People

(Reporter: Keith Lea, Assigned: Ben Goodger (use ben at mozilla dot org for email))

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.5) Gecko/20031007 Firebird/0.7
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.5) Gecko/20031007 Firebird/0.7

The use of Cooper Black in conjunction with so many other fonts makes the
Firebird page look awkward and unprofessional. Two of the two friends of mine
I've talked to about this agree. Cooper Black almost always looks awkward and
dumb, in my opinion, but reducing the number of fonts on the page would improve
the site as well. There is currently a pretty big number of fonts used:

1. "mozilla" in logo
2. "FIREBIRD" in logo
3. Cooper Black
4. "mozilla" in download box (only on front page)
5. Arial in download select box
6. Verdana for feature list, rest of page text

I think this should be trimmed down to use maybe two or three fonts, and I think
the use of Cooper Black should be eliminated. (The two friends agree that Cooper
Black looks bad on the page.)

Reproducible: Always

Steps to Reproduce:
1.
2.
3.
(Reporter)

Comment 1

15 years ago
I found a seventh font: the NOW text. It looks like it might be the same font as
FIREBIRD, but without the fire effects applied.
-> page owner
Assignee: endico → bugs

Comment 3

15 years ago
page redesigned on Oct 15 12:27
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → FIXED
Product: mozilla.org → Websites
Component: www.mozilla.org → General
Product: Websites → www.mozilla.org
You need to log in before you can comment on or make changes to this bug.