Closing and reopening window breaks keyword shortcuts.

RESOLVED FIXED

Status

()

Firefox
General
RESOLVED FIXED
15 years ago
15 years ago

People

(Reporter: Daniel Pfile, Assigned: Blake Ross)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.5) Gecko/20031007 Firebird/0.7
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.5) Gecko/20031007 Firebird/0.7

I have a keyword shortcut to search google. So when I type g <keyword> I get the
search results from google. When I close and reopen the browser window g
<keyword> stops working and starts doing I feel lucky searches on 'g <keyword>'.
It happens with every keyword shortcut, even those without search options.

Reproducible: Always

Steps to Reproduce:
1. Close window
2. Try keyword search

Actual Results:  
An I feel lucky search happens on the keyword and it's options.

Expected Results:  
What the keyword feature should do.

Comment 1

15 years ago
when i type "g" it starts type ahead find.  please explain exactly what your
procedure is.
(Reporter)

Comment 2

15 years ago
I'm sorry, that should be after hitting command-l or clicking in the location bar.

In the steps to reproduce there should be a 1.5: Open new window, if that wasn't
clear.

Comment 3

15 years ago
I'm guessing this is an effect of Bug 206752
(Reporter)

Comment 4

15 years ago
You're right, it is another symtom of <a href="http://bugzilla.mozilla.org/
show_bug.cgi?id=206752">Bug 206752</a>. The workaround mentioned in the comments there 
works for this as well. So it looks like a few things are happening in the wrong place. I don't know 
my way around the code good enough to be able to figure out exactly where...

Comment 5

15 years ago
can someone confirm that this was fixed (or not) in 0.7.1?

Comment 6

15 years ago
Don't use 0.7.1, but I can confirm it's fixed in the 20031029 Firebird/0.7+ nightly.

Comment 7

15 years ago
Works For Me too on 0.7.1. Resolving as Fixed.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.