After opening 'group of tabs' bookmark, 'back' button enabled and applies to all tabs

RESOLVED INVALID

Status

SeaMonkey
Tabbed Browser
--
trivial
RESOLVED INVALID
14 years ago
9 years ago

People

(Reporter: Dan Moore, Assigned: Pierre Chanial)

Tracking

Trunk
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.5) Gecko/20031007
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.5) Gecko/20031007

After opening a bookmark that was created by the 'bookmark this group of tabs'
option, the back button is enabled on every tab.  The result of clicking the
back button is that all the tabs that were opened by the group bookmark
disappear, and the browser is back in the state it was before the bookmark tab
group was opened.

While this functionality is consistent with what happens when you load a normal,
single bookmark, I think it is inconsistent with regards to the 'back',
'forward', 'reload', 'stop', and even the URL/location box UI elements since in
every other case they only affect the current tab.

I'd suggest that either the back button be disabled for the case of loading a
bookmark group, or that going 'back' would result in only the current tab changing.

Reproducible: Always

Steps to Reproduce:
1.  Start Mozilla
2.  Load web pages in at least two tabs
3.  Use the Bookmarks>Bookmark this Group of Tabs menu option
4.  Close Mozilla
5.  Start Mozilla
6.  Find the Bookmark created in step 3 and open it
7.  Click 'back'

Actual Results:  
All the newly created tabs disappear and the browser is back to just displaying
what it is set to display upon being freshly started in a single tab.

Expected Results:  
I'd suggest that either the back button be disabled for the case of loading a
bookmark group, or that going 'back' would result in only the current tab changing.

Comment 1

14 years ago
This is intentional. From the release notes "Back and Forward navigation for
tabbed browsing and bookmark groups has been improved. Users can now use the
back button after loading a bookmark group to restore the previous set of tabs."
Why would you want to go back on just one page anyway? 

I'm thinking invalid...
Component: Bookmarks → Tabbed Browser
(Reporter)

Comment 2

14 years ago
I'm not saying that I *want* to go back on just one page.  My thinking is that
"Reload" doesn't reload all those tabs, so why should "Back" (and then
subsequently "Forward" as well) affect them all?

The reason I suggested having it only go back on the current tab is that it
would be consistent with rest of the back/forward/reload/stop<->tabbed interface
as well as be consistent with what 'back' does when loading a normal/single
bookmark.

Thanks for pointing out that it is an intentional choice.  If I had realized
that I probably wouldn't have filed this in Bugzilla, but instead tried to find
a place to discuss this.

Comment 3

14 years ago
I agree that it's not the same as usual. I'm guessing it's basically for if you
accidentally hit the groupmark, you can get back all the old pages you were at
before, since the groupmark now replaces instead of appends by default. I think
once you go anywhere on any of the pages, the Back button returns to normal
behaviour.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → INVALID

Comment 4

13 years ago
*** Bug 263022 has been marked as a duplicate of this bug. ***

Comment 5

13 years ago
*** Bug 242540 has been marked as a duplicate of this bug. ***
Product: Core → SeaMonkey
You need to log in before you can comment on or make changes to this bug.