Requests and pop up window preview in sidebar

RESOLVED WORKSFORME

Status

SeaMonkey
Sidebar
--
enhancement
RESOLVED WORKSFORME
15 years ago
13 years ago

People

(Reporter: boris, Assigned: shliang)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; de-AT; rv:1.5) Gecko/20031007
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; de-AT; rv:1.5) Gecko/20031007

To clean up the workplace and to reduce junk on the screen I suggest following
feature.
Popup and request windows would open (optionally to the current design) in the
sidebar and can be magnified by pressing a button which opens a new tab or
window, with the same content.
An example:
The user clicks a link to download data
The request to save the data opens inside the sidebar. (with an option to save
into the download directory or to select the directory)
It would also be nice to have the download manager integrated to the sidebar to
have an overview of current downloads or even a list of downloads, which are not
assigned to a save directory yet.
Another one:
A new web page is opened
A pop-up window appears in the sidebar (the pop-up blocker is set to "preview on
sidebar") together with buttons: "open window: now, always, never"

This would help to keep the view stable and free of clutter (no hiding of
information and sudden popups, which are very annoying for the user - since they
are completely unnatural - and increase stress)

Reproducible: Always

Steps to Reproduce:
1.
2.
3.

Comment 1

15 years ago
Is this meant to be similiar how Opera handles downloads?
Product: Browser → Seamonkey
This is an automated message, with ID "auto-resolve01".

This bug has had no comments for a long time. Statistically, we have found that
bug reports that have not been confirmed by a second user after three months are
highly unlikely to be the source of a fix to the code.

While your input is very important to us, our resources are limited and so we
are asking for your help in focussing our efforts. If you can still reproduce
this problem in the latest version of the product (see below for how to obtain a
copy) or, for feature requests, if it's not present in the latest version and
you still believe we should implement it, please visit the URL of this bug
(given at the top of this mail) and add a comment to that effect, giving more
reproduction information if you have it.

If it is not a problem any longer, you need take no action. If this bug is not
changed in any way in the next two weeks, it will be automatically resolved.
Thank you for your help in this matter.

The latest beta releases can be obtained from:
Firefox:     http://www.mozilla.org/projects/firefox/
Thunderbird: http://www.mozilla.org/products/thunderbird/releases/1.5beta1.html
Seamonkey:   http://www.mozilla.org/projects/seamonkey/
(Reporter)

Comment 3

13 years ago
meanwhile resolved by extension to firefox (download managing tools)
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → FIXED

Updated

13 years ago
Status: RESOLVED → UNCONFIRMED
Resolution: FIXED → ---

Comment 4

13 years ago
We don't know what fixed this worksforme
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago13 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.