libart SVG build fails for Mozilla 1.5 ( libart_lgpl No rule to make target `export'. Stop.)

RESOLVED WONTFIX

Status

()

Core
SVG
RESOLVED WONTFIX
14 years ago
12 years ago

People

(Reporter: Gyles Harvey, Unassigned)

Tracking

Trunk
Sun
SunOS
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 Galeon/1.2.11 (X11; SunOS sun4u; U;) Gecko/20030713
Build Identifier: http://ftp.mozilla.org:80/pub/mozilla.org/mozilla/releases/mozilla1.5/src/mozilla-source-1.5.tar.bz2

My attempt to build a SVG enabled mozilla fails in exactly the same manner as
bug #126509

Reproducible: Always

Steps to Reproduce:
CVSROOT=:pserver:anonymous@cvs-mirror.mozilla.org:/cvsroot
MOZ_INTERNAL_LIBART_LGPL=1
export CVSROOT MOZ_INTERNAL_LIBART_LGPL
cvs co -r MOZILLA_1_5_RELEASE mozilla/client.mk
cd mozilla
make -f client.mk checkout

in my mozconfig:

ac_add_options --enable-svg
mk_add_options MOZ_INTERNAL_LIBART_LGPL=1
(+ others)
Actual Results:  
build failed:

make[3]: Entering directory `/usr/src/mozilla/other-licenses/libart_lgpl'
make[3]: *** No rule to make target `export'.  Stop.
make[3]: Leaving directory `/usr/src/mozilla/other-licenses/libart_lgpl'

Expected Results:  
build continued.

I tried manually pulling libart from HEAD, but 
make -f client.mk checkout
then just wiped it out again with lots of lines like:

cvs server: mozilla/other-licenses/libart_lgpl/art_alphagamma.c is no longer in
the repository
Looks like we didn't tag the libart_lgpl stuff with the branch tag... not sure
whether we should have; timeless had some thoughts on the matter.
Summary: libart SVG build fails for Mozilla 5.1 ( libart_lgpl No rule to make target `export'. Stop.) → libart SVG build fails for Mozilla 1.5 ( libart_lgpl No rule to make target `export'. Stop.)

Comment 2

14 years ago
So, what should we do to compile Mozilla 1.5 with SVG support?
(Reporter)

Comment 3

14 years ago
I managed a build by pulling libart from 'HEAD' - no idea if it works yet though.

cvs co -r HEAD mozilla/other-licenses/libart_lgpl

Hardly elegant...

Comment 4

14 years ago
Same problem when trying to build mozilla 1.6b
According to timeless the concern is that people who check out on tags won't
realize that they're checking out and building code under other licenses since
we normally force people to set an environment variable to get other licensed
code. One possible course of action would be to provide a LIBART_CO_TAG, but he
doesn't have the time right now. 
Mass reassign of SVG bugs that aren't currently being worked on by Alex to
general@svg.bugs. If you think someone should be assigned to your bug you can
join the #svg channel on mozilla.org's IRC server ( irc://irc.mozilla.org/svg )
where you can try to convince one of the SVG hackers to work on it. We aren't
always there, so if you don't get a response straight away please try again later. 
Assignee: alex → general
This is an automated message, with ID "auto-resolve01".

This bug has had no comments for a long time. Statistically, we have found that
bug reports that have not been confirmed by a second user after three months are
highly unlikely to be the source of a fix to the code.

While your input is very important to us, our resources are limited and so we
are asking for your help in focussing our efforts. If you can still reproduce
this problem in the latest version of the product (see below for how to obtain a
copy) or, for feature requests, if it's not present in the latest version and
you still believe we should implement it, please visit the URL of this bug
(given at the top of this mail) and add a comment to that effect, giving more
reproduction information if you have it.

If it is not a problem any longer, you need take no action. If this bug is not
changed in any way in the next two weeks, it will be automatically resolved.
Thank you for your help in this matter.

The latest beta releases can be obtained from:
Firefox:     http://www.mozilla.org/projects/firefox/
Thunderbird: http://www.mozilla.org/products/thunderbird/releases/1.5beta1.html
Seamonkey:   http://www.mozilla.org/projects/seamonkey/
Marking wontfix. We have no plans to continue development of the libart backend.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.