If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Erradic Backspace Behaviour

VERIFIED DUPLICATE of bug 22233

Status

()

Core
Layout: Form Controls
P3
normal
VERIFIED DUPLICATE of bug 22233
18 years ago
18 years ago

People

(Reporter: Stephen Anderson, Assigned: Joe Francis)

Tracking

Trunk
x86
Windows 95
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

18 years ago
The conditions described herein were observed with build 1999122011 on Win95.

Behaviour Observed:
Under certain conditions (described below) the backspace key will cause a
several character backwards jump just prior to backspacing.

Expected behaviour:
Backspace key always backspaces over element just prior to text caret.

Steps to reproduce:
1) Fire up mozilla.
2) Goto http://bugzilla.mozilla.org/show_bug.cgi?id=22023
3) Scroll down and click in the additional comments text box
4) Type in four lines of text.  Example:
gkdfgjfdklj fg fgdjhlkj gfhd lkjh fgh gfdh
fgh fgh fgh fgh fgh
fgh kjfghkljk lsgjklhfdg fgh kljhdf
dfhklj fdhklj fghlkjfgh fgh
5) Click on the end of the second line to place the text cursor and type some
additional charachters or words.
6) Attempt to backspace over the last word you typed.

The steps layed out are as they are because if you just type and then tro to
backspace it works fine.  It has something to do with clicking on a previously
typed line.  It _very_ annoying for proof-reading and correcting spelling mistakes.

Updated

18 years ago
Assignee: karnaze → buster

Comment 1

18 years ago
Reassigning to Steve.

Updated

18 years ago
Assignee: buster → jfrancis
Target Milestone: M13

Comment 2

18 years ago
joe, this looks like a case of the delete code we worked on a few weeks ago
either regressing, or maybe this case never worked right?  I was able to
reproduce with debug code from 12/20 on windows.
(Assignee)

Updated

18 years ago
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → DUPLICATE
(Assignee)

Comment 3

18 years ago
this is actually a dup of 22233, even though it looks different.


*** This bug has been marked as a duplicate of 22233 ***

Updated

18 years ago
Status: RESOLVED → VERIFIED

Comment 4

18 years ago
[bugday] verified as duplicate.
You need to log in before you can comment on or make changes to this bug.