If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Mozilla fails at several tests in the W3C CSS1 Test suite

VERIFIED INVALID

Status

()

Core
CSS Parsing and Computation
VERIFIED INVALID
14 years ago
14 years ago

People

(Reporter: aceman, Assigned: dbaron)

Tracking

Trunk
x86
Windows 98
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/4.0 (compatible; MSIE 5.5; Windows 98)
Build Identifier: Firebird 0.7

I think these tests show a bug in Mozilla:
0.4 - some problem in including stylesheets from other folders
6.4 - white background not shown as the comments say (actually this may be the 
same problem as above, because the rules are included from another folder/file)
2.6 - If the first-line of a paragraph has a high character in it, there is 
empty vertical space after it, separating it from the rest of the paragraph. 
There is nothing in this space, therefore it shouldn't be necessary. I don't 
know if it is incorrect rendering, but it is ugly.

Reproducible: Always

Steps to Reproduce:
1. Check the mentioned sections in the Test suite.

Comment 1

14 years ago
I'm not sure what you mean by 2.6, but it seems that 0.4 and 6.4 are invalid,
since the directory "folder" is missing or the files which should be within
"folder" are missing.
Regarding section 2.6, it is correct rendering.  CSS3 provides better ways of
doing drop caps and initial caps.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → INVALID
(Reporter)

Comment 3

14 years ago
You may be right. As I thought about it, the space can be caused by the first
letter increasing the line height of the first line. Incidentally, there is no
letter which would span below the base line, but there could be. As I said, it
may be correct, but ugly.

Comment 1: I didn't check that. Could you contact the test authors about the
problem?

Anyway, I agree with closing this bug. Sorry for taking your time.
(Reporter)

Comment 4

14 years ago
The problems were fixed at W3C. The mentioned files and folders were corrected 
and the test pages render correctly - according to the descriptions.

Now this bug can really be closed.
(Reporter)

Updated

14 years ago
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.