Browser crash on trying to open such a file (pcf), perhaps, a dialog 'unknown content type' should be opened instead?

RESOLVED WORKSFORME

Status

Core Graveyard
GFX: Gtk
--
critical
RESOLVED WORKSFORME
14 years ago
9 years ago

People

(Reporter: Valia V. Vaneeva, Assigned: blizzard)

Tracking

({crash, stackwanted})

Trunk
x86
Linux
crash, stackwanted

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.5) Gecko/20031011
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.5) Gecko/20031011

Browser crash on trying to open such a file (pcf), perhaps, a dialog 'unknown
content type' should be opened instead?

Reproducible: Always

Steps to Reproduce:
1. Open URL in browser, doesn't matter how you do that.

Actual Results:  
Mozilla crashes.

Expected Results:  
A dialog 'unknown content type' should be opened.

Comment 1

14 years ago
mime type is text/plain so Mozilla will display it.
Are you using an XFT build ? If so, please make sure that you don't have any
font files that aren't world readable in your font path.  Also, make sure you
don't have any .fon files in your path.  Also check the output of:

NSPR_LOG_MODULES=XftFontLoad:5 ./mozilla

That will give you a clue as to which font or set of fonts is causing problems.

Shortcut: probably "sserife.fon" and "sseriff.fon"
If so, then this is dupe of bug 180309.
Severity: normal → critical
Keywords: crash, stackwanted
(Reporter)

Comment 2

14 years ago
I use a gtk2 build and don't have .fon's. Anyway, I'll take another look at this
problem, perhaps it's really just a dupe.
The question was whether you use an xft build, not what version of gtk2....

Over to blizzard, since this sounds like an xft bug indeed.
Assignee: file.handling → blizzard
Component: File Handling → GFX: Gtk
QA Contact: ian
Whiteboard: DUPEME
(Assignee)

Updated

14 years ago
Blocks: 198955

Comment 4

14 years ago
do you crash using latest pre-1.6 build or the Firebird XFT build ?
This is probably fixed via bug 213734.
http://ftp.mozilla.org/pub/mozilla.org/mozilla/nightly/latest-1.6/
http://ftp.mozilla.org/pub/mozilla.org/firebird/nightly/latest-0.8/

Comment 5

13 years ago
Works for me with Firefox 1.0.2 on Windows XP SP2.  Also, since this bug has had
no action, and the reporter has not responded to queries, I'm marking a WFM.

Reporter, if you feel this was done in error please REOPEN.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → WORKSFORME
Whiteboard: DUPEME
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.