html-composed mail results in "is not a registered protocol" alert when clicking a link

VERIFIED DUPLICATE of bug 216154

Status

MailNews Core
MIME
VERIFIED DUPLICATE of bug 216154
15 years ago
10 years ago

People

(Reporter: Rein Smedinga, Assigned: (not reading, please use seth@sspitzer.org instead))

Tracking

Trunk
x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.5) Gecko/20031007
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.5) Gecko/20031007

I receive mail composed in html. When clicking on a link in that mail the alert
window saying "is not a registered protocol" pops up. In cannot use the links in
the mail.

Reproducible: Always

Steps to Reproduce:
1. select a mail that is composed as html
2. click on a link in the text of the mail
3. the alert window pops up

Actual Results:  
alert window pops up.

Expected Results:  
should open a browser window and show the content of the page the link is
refering to.

Bug seems to be similar to bug 210164 and/or 195410

Situation happens since mozilla 1.5. I did not had this problem in 1.4
(Reporter)

Comment 1

15 years ago
Created attachment 133412 [details]
a html-composed mail that has the problem described
(Reporter)

Comment 2

15 years ago
I just noticed that links that course the problem are internal links to a part
further down in the mail. At the bottom of the window the links occur something like

/#4 

A complete http-link works fine.
This is bug 216154 

*** This bug has been marked as a duplicate of 216154 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
Verified DUP.
Status: RESOLVED → VERIFIED
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.