If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Autocomplete remembers non-existent addresses

RESOLVED DUPLICATE of bug 9203

Status

SeaMonkey
Location Bar
RESOLVED DUPLICATE of bug 9203
14 years ago
9 years ago

People

(Reporter: Andre-John Mas, Assigned: Joe Hewitt (gone))

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.5) Gecko/20030925
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.5) Gecko/20030925

If I type in a URL that does not exist, say 'www.appsaaxsd.com', the browser
will show a dialogue indicating that the address can not be found. If I then, in
start typing a new address 'www.app', when wanting to type 'www.apple.com', I
get the bad address as an option. This address should not be saved if the
browser could not resolve the URL. Note - this is applicable to when Verisign's
'Site Finder' is not active.

Reproducible: Always

Steps to Reproduce:
1. Type in a URL for a non-existent server and hit enter
2. Start typing a URL similar to the non-existent server
3. 

Actual Results:  
The non-existent server shows up in the list.

Expected Results:  
If the server could not be resolved then is should not show up in the list,
unless it had been resolvable in the past by the browser, i.e. the test should
only apply to adding addresses to the list, not to the current contents.

Comment 1

14 years ago
see also bug 66049.

*** This bug has been marked as a duplicate of 9203 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
Product: Core → SeaMonkey
You need to log in before you can comment on or make changes to this bug.