Closed Bug 222483 Opened 18 years ago Closed 18 years ago

Be able to disabled focus() javascript

Categories

(SeaMonkey :: Preferences, enhancement)

x86
Windows 2000
enhancement
Not set
normal

Tracking

(Not tracked)

VERIFIED DUPLICATE of bug 124750

People

(Reporter: Jean-Marc, Assigned: bugs)

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.5) Gecko/20031007
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.5) Gecko/20031007

When using tab browsing, javascript focus on a hide tab will take the focus of
the current tab, so, you will sometime write your very secret defense password
in a viewable field on another tab without nowing where ... So, it will be very
usefull to add the possibility to disable the focus() method like other metho in
the javascrip option panel ...

Reproducible: Always

Steps to Reproduce:
1.go to the site of your choise and place the cursor in a form.
2.go to http://games.mountyhall.com to a new tab and come back to your first tab
3.write in you form, and, when the other tab finish to load, you will see your
cursor disappear ...

Actual Results:  
You are writing in the wrong field ...

Expected Results:  
stay in the right form/field ...
doesn't edit\preferences\Scripts&Plugins/Raise or lower window do that ?
---> Prefs
Assignee: rogerl → bugs
Component: JavaScript Engine → Preferences
QA Contact: PhilSchwartau → sairuh
About edit\preferences\Scripts&Plugins/Raise or lower window ...

No, this option doen't protect from focus lost to other tab.

*** This bug has been marked as a duplicate of 124750 ***
Status: UNCONFIRMED → RESOLVED
Closed: 18 years ago
Resolution: --- → DUPLICATE
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.