If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

window.open() called via onclick() opens two windows when only one is expected

RESOLVED INVALID

Status

()

Core
DOM: Core & HTML
RESOLVED INVALID
14 years ago
14 years ago

People

(Reporter: Álvaro González, Unassigned)

Tracking

Trunk
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.5) Gecko/20031007
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.5) Gecko/20031007

Code following this pattern doesn't work as expected:

<a href="" onclick="return my_window_open_funcion()">

While my_window_open_funcion() is written to open one window, two windows are
actually opened.

Reproducible: Always

Steps to Reproduce:
1. Load attached testcase in Mozilla
2. Click on first link (labeled as "Wrong")

Actual Results:  
Two 200x100 windows are opened

Expected Results:  
Open only one 200x100 window

<script language="JavaScript"><!--
	function popup(){
		window.open('about:blank', '', 'width=200,height=100');
		return false;
	}
//--></script>
<a href="about:blank" onclick="return popup()">Wrong</a>
(Reporter)

Comment 1

14 years ago
Created attachment 133499 [details]
Test case
-> DOM0
Assignee: rogerl → dom_bugs
Component: JavaScript Engine → DOM Level 0
QA Contact: PhilSchwartau → ashshbhatt

Comment 3

14 years ago
WFM: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.6a) Gecko/20031011
(Reporter)

Comment 4

14 years ago
I've been able to reproduce the problem in second computer with similar specs.
The problem started when I installed this extension:

tabextensions_en.xpi v1.9.2003101801 (latest version)

It can be downloaded from here:

http://white.sakura.ne.jp/~piro/xul/_tabextensions.html.en#download
(Reporter)

Comment 5

14 years ago
Previous version on the extensin (1.8.2003082001) works fine where latest failed.
Since the bug is most likely on the extension side, I suppose it can be marked
as "invalid" and closed.

Comment 6

14 years ago
WFM, 2003-10-16-05 trunk ans Mozilla 1.5 Linux.

(I have sent a mail to piro@p.club.ne.jp about the issue).

-> INVALID
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → INVALID

Comment 7

14 years ago
(I got a reply from Piro and there is now a testing version with a fix for
 this problem available.)
You need to log in before you can comment on or make changes to this bug.