IMAP subfolders are not correctly identified as allowing subfolders

RESOLVED WORKSFORME

Status

RESOLVED WORKSFORME
15 years ago
12 years ago

People

(Reporter: edloper, Assigned: mscott)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.0)
Build Identifier: Mozilla Thunderbird 0.3 (20031013)

I am using an IMAP server that does not support folders containing both sub-
folders and messages.  So folders should be grouped into 2 classes: folders 
that contain messages and folders that contain subfolders.  Folders that only 
contain subfolders should be shown italicized and in gray.  Each time I run 
thunderbird, it shows *some* of the folders-containing-subfolders, but not 
all.  The set that it picks to show italicized and gray seems pretty random.  
This problem does not occur on mozilla, so it has kept me from switching from 
mozilla to thunderbird.

Reproducible: Always

Steps to Reproduce:
1.Uncheck tools->account settings->server settings->advanced->server supports 
folders that contain sub-folders and messages
2.create lots of folders of each type (containing subfolders only and 
containing messages).  (I have about 100 folders, nested up to depth 4 or 5)
3.close thunderbird, run thunderbird.

Actual Results:  
*Some* of the folders-containing-subfolders are in gray and italics (detected 
as containing only subfolders)

Expected Results:  
*All* of the folders-containing-subfolders are in gray and italics (detected as 
containing only subfolders)

Comment 1

15 years ago
I've had this same problem with tbird since I started running version 0.1 on my
RH 9 box w/ Ximian XD2 installed. It continued in 0.2 and remains in 0.3. I am
using courier-imap 1.5.3 to serve my mail store and IMAPS protocol to connect.

At startup, the list of folders in the Folder pane on the left side is
incomplete. Many folders that have subfolders do not have the turn-down icon
next to them. I have to close and re-open the top level folder to get its
children to display properly and then have to close/open each child folder that
has subfolders as well. Until I do this they do not present properly and tbird
does not check the subfolders for incoming email.

You can see an example of this by looking at:

http://www.bearcircle.net/~lance/tbird-bugs/tbird1.png
and
http://www.bearcircle.net/~lance/tbird-bugs/tbird2.png

tbird1.png shows my tbird window with the Inboxes folder and its subfolders
displayed. tbird2.png shows Inboxes after I have closed and re-opened it. It now
has subfolder turndown next to several folders that were missing previously.

Nothing I've tried fixes this problem. Can anyone offer advice or is this a
genuine bug?

Comment 2

15 years ago
I've found a bug (and a solution) which might cause several different problems.
Maybe your's is one of them. Please see my bug report <a
href="http://bugzilla.mozilla.org/show_bug.cgi?id=230055">230055</a> and check
if changed settings will solve your problem.

You may re-check your problem with a decreased value of "max. number of cached
server connections" (default=5, my suggestion=3 or 4). Perhaps it does solve
your problem.

While inspecting my bug I found that sometimes folders containing subfolders
weren't being displayed as having subfolders. After changing my settings
everything works fine. Perhaps your problem is related to the same bug. Checked
only with courier-imap but others (cyrus) should behave the same.

Comment 3

15 years ago
I had modified the MAXPERIP setting in my courier-imap 2.2.1 configuration to 6
and was using 6 connection in Thunderbird 0.4.

I changed the MAXPERIP to 4 and set thunderbird to use only 3 connections but my
issue remains.  Subfolders are not properly marked as subfolders and I have to
close and open their parent folder before they are recognized correctly.

I'm sorely tempted to switch over to IMAP instead of IMAP-SSL for a while so I
can trace the network traffic and determine what is going on.

Comment 4

12 years ago
you could always generate an client side imap protocol log:

http://www.mozilla.org/quality/mailnews/mail-troubleshoot.html#imap
(Reporter)

Comment 5

12 years ago
This bug is fixed (for me) in the current version of Thunderbird.  (I'm running 1.5.0.8)
Status: NEW → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.