Support for multiple firebird processes

VERIFIED DUPLICATE of bug 135137

Status

()

Firefox
General
--
enhancement
VERIFIED DUPLICATE of bug 135137
15 years ago
14 years ago

People

(Reporter: Kevin Dente, Assigned: Blake Ross)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.5) Gecko/20031007 Firebird/0.7
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.5) Gecko/20031007 Firebird/0.7

It would be very nice if Firebird supported the ability to run multiple Firebird
processes (as an option). There are times when I'm doing some important bit of
work on a web page (say, filling out a long and complicated form), and I want to
eliminate the risk that navigating to another page in another browser window
might cause me to lose the work I've done in the first. If, for example, the
browser crashes or hangs due to a bug, or a bug in a plug-in kills the browser,
or an OS resource limitation on a stressed machine causes browser problems, then
I've lost my work in the original window. Being able to protect against that by
launching an additional browser process can be a very handy thing. This is
especially true while the browser is in early development, like now, but even
once it's released it would continue to be useful. An extensible application
like Firebird is at risk from 3rd party plugins, no matter how solid the
Firebird code is.

Reproducible: Always

Steps to Reproduce:
1.
2.
3.

Comment 1

15 years ago
set MOZ_NO_REMOTE=1

Set this environment variable in control panel-system (or in a batch file before
running mozillafirebird.exe). After doing that, all attempts to start Firebird
will open a new instance. This was implemented by bug 131805.

But you can't use the same profile. This is bug 135137.

-> marking as duplicate of bug 135137.

*** This bug has been marked as a duplicate of 135137 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE

Comment 2

14 years ago
verified dupe.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.