bugzilla.mozilla.org has resumed normal operation. Attachments prior to 2014 will be unavailable for a few days. This is tracked in Bug 1475801.
Please report any other irregularities here.

make it clear how to download localized versions from home page

RESOLVED DUPLICATE of bug 13146

Status

www.mozilla.org
General
RESOLVED DUPLICATE of bug 13146
15 years ago
6 years ago

People

(Reporter: Dawn Endico, Assigned: Dawn Endico)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Assignee)

Description

15 years ago
right now its unclear how to get mozilla in other languages.
the link to the releases page only says "more..."

Comment 1

15 years ago

*** This bug has been marked as a duplicate of 13146 ***
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
Product: mozilla.org → Websites
Component: www.mozilla.org → General
Product: Websites → www.mozilla.org
You need to log in before you can comment on or make changes to this bug.