function addNetscapePanel() adds boomark

RESOLVED INVALID

Status

()

Firefox
Bookmarks & History
RESOLVED INVALID
14 years ago
11 years ago

People

(Reporter: Galileo Vidoni, Assigned: Pierre Chanial)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.5) Gecko/20031007 Firebird/0.7
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.5) Gecko/20031007 Firebird/0.7

wow... I was really stranged to find that... perhaps because of a bug? or was it
intentional?, Mozilla Firebird reactes to the add.NetscapePanel function with an
"Add Bookmark" dialog, instead of adding a Sidebar Panel (WebPanel it's called
in FBird, i guess...). I have heard and noted that Sidebar Panels aren't fully
implemented (the sidebar looks like a horrible imitation of M$IE's personal
bars), but what I've never thought before was that it was going to react in a so
incoherent way. It doesn't looks as a Linux-specific issue, but I marked it as
LInux-only just cause I haven't tested it in M$ Windoze. If the idea is to
implement a way of auto-adding bookmarks, I will be necessary to implement the
M$IE's addBookmark function, as it's sadly a standard... Perhaps not recognized
by the W3C, but every website uses it.

Reproducible: Always

Steps to Reproduce:
1.Try to add a Sidebar Panel in Fbird
2.Look what happens
3.Wow! Too much IEish, don't you think?

Actual Results:  
An "Add Bookmark" dialog appears

Expected Results:  
To add a Sidebar Psnel accessible, at least, via View-->Sidebar
it adds the sidebar URL version as a bookmark that is set to open in the sidebar.

this is how the sidebar impl works in Firebird, whether you like it or not.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → INVALID
sorry for bugspam, long-overdue mass reassign of ancient QA contact bugs, filter on "beltznerLovesGoats" to get rid of this mass change
QA Contact: mconnor → bookmarks
You need to log in before you can comment on or make changes to this bug.