java plugin fails to load because of unresolved symbol in libjavaplugin

RESOLVED DUPLICATE of bug 209834

Status

()

Core
Plug-ins
--
major
RESOLVED DUPLICATE of bug 209834
15 years ago
15 years ago

People

(Reporter: Ernst Taumberger, Assigned: Peter Lubczynski)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.5) Gecko/20031007
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.5) Gecko/20031007

the java plugin fails to load with the error message:

LoadPlugin: failed to initialize shared library
/usr/local/mozilla-1.5/mozilla/plugins/java2/plugin/i386/ns600/libjavaplugin_oji.so
[/usr/local/mozilla-1.5/mozilla/plugins/java2/plugin/i386/ns600/libjavaplugin_oji.so:
undefined symbol: __vt_17nsGetServiceByCID]

the java plugin has been downloaded from from the official netscape site


Reproducible: Always

Steps to Reproduce:
1. start mozilla
2. mozilla starts, but without the java plugin
3.

Actual Results:  
no plugin loaded

Expected Results:  
java plugin loaded

using the java plugin from Suns j2re1.4.2_01 causes mozilla to abort at startup,
like this: 

INTERNAL ERROR on Browser End: No manager for initializing factory?

System error?:: Success

Comment 1

15 years ago
This version has not worked with Mozilla since 1.4.  You need a different Java
version.  See http://www.mozilla.org/releases/mozilla1.4.1/README.html#new-issues

*** This bug has been marked as a duplicate of 209834 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE

Comment 2

15 years ago
Also http://www.mozilla.org/releases/mozilla1.5/known-issues.html#java

Generally it's good to review the release notes before filing bugs.
You need to log in before you can comment on or make changes to this bug.