The transformed xml to html file does not work. The function in the javascript is not defined.

RESOLVED DUPLICATE of bug 221862

Status

()

Core
XSLT
RESOLVED DUPLICATE of bug 221862
15 years ago
15 years ago

People

(Reporter: Jeanine Meyer, Assigned: peterv)

Tracking

Trunk
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.5) Gecko/20031007

This is what javascript: produces.

Error: event.target.rel has no properties
Source File: chrome://global/content/bindings/tabbrowser.xml
Line: 589

Error: start is not defined
Source File: javascript:start();
Line: 1

Reproducible: Always

Steps to Reproduce:
1.Go to the website:
http://newmedia.purchase.edu/~Jeanine/interfaces/vdog.xml
2.Click on Start Play
3..... nothing happens.

Note: using saxon, the html produced is located at
http://newmedia.purchase.edu/~Jeanine/interfaces/vdog.html

Actual Results:  
Nothing happens.  When I enter in javascript:
the errors reported up in Details appear.
I have no idea what chrome: or event.target.rel refer to.

Expected Results:  
Click on the saxon produced html (or browse using IE) to see results).
The weight text field goes down. Eventually the dog dies, unless it is fed, 
etc.

Repeating above: the is an xsl transform of a xml file that defines a 'virtual 
pet' to be simulated by HTML and JavaScript code.

Comment 1

15 years ago
xsl:comment is bad. see the arguments in bug 221862

*** This bug has been marked as a duplicate of 221862 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE

Comment 2

15 years ago
I learned that too. Thanks Axel.
You need to log in before you can comment on or make changes to this bug.