Text color of link destination in Status Bar is not the correct color as defined by Windows theme.

VERIFIED DUPLICATE of bug 220031

Status

()

Firefox
General
--
minor
VERIFIED DUPLICATE of bug 220031
15 years ago
11 years ago

People

(Reporter: Sarkoon, Assigned: Blake Ross)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.5) Gecko/20031007 Firebird/0.7
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.5) Gecko/20031007 Firebird/0.7

When you move your cursor over a link, the link destination appears in the
status bar in the lower left of the window. The color of this text is currently
hard coded to black, whereas it should be read from the current windows theme.

Example: http://www.sarkoon.com/stuff/mozillalinktextbug.htm

Reproducible: Always

Steps to Reproduce:
1. Change your Windows XP Theme to something that causes the status bar to be
filled with a dark color. Custom themes can be downloaded from www.themexp.org.
2. Launch Firebird, move cursor over a link.

Actual Results:  
The link displayed in the status bar is displayed as black text on a black
status bar. I can't read it.

Expected Results:  
Displayed the link in white text instead of black. (As defined by my current
Windows theme)

Other programs (like internet explorer) do this properly.

Comment 1

15 years ago
In GNOME the status bar isn't themed, so I can't recreate this, but the title
bar seems to be OK.

I'm confirming though I can't see it.
Severity: normal → minor
Status: UNCONFIRMED → NEW
Ever confirmed: true

Updated

15 years ago
Blocks: 223959

Updated

15 years ago
No longer blocks: 223959
QA Contact: bugzilla

Updated

15 years ago
Blocks: 223959

Comment 2

15 years ago
I knew i'd seen this (commented on this...) before. :0)

*** This bug has been marked as a duplicate of 220031 ***
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE

Updated

13 years ago
Status: RESOLVED → VERIFIED
QA Contact: bugzilla → general

Updated

11 years ago
No longer blocks: 223959
You need to log in before you can comment on or make changes to this bug.